# CVE-2025-62705: OpenBao and Vault Leak []byte Fields in Audit Logs

> OpenBao fails to redact binary fields in audit logs, potentially exposing sensitive data like public keys or raw secrets to log readers.

- **Severity:** Medium 5.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Oct 2025
- **Updated:** 23 Oct 2025
- **Also known as:** BIT-openbao-2025-62705, GHSA-rc54-2g2c-g36g, GO-2025-4052

## What is CVE-2025-62705?

CVE-2025-62705 is a medium-severity vulnerability in openbao, published on 22 Oct 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

OpenBao is an open source identity-based secrets management system. Prior to version 2.4.2, OpenBao's audit log did not appropriately redact fields when relevant subsystems sent []byte response parameters rather than strings. This includes, but is not limited to sys/raw with use of encoding=base64, all data would be emitted unredacted to the audit log, and Transit, when performing a signing operation with a derived Ed25519 key, would emit public keys to the audit log. This issue has been patched in OpenBao 2.4.2.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2025-62705?

4 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20251022165510-cc2c476bac66 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20251022165510-cc2c476bac66 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20251022165510-cc2c476bac66 |
| `openbao` | Bitnami | All versions | 2.4.2 |

Products: Openbao Openbao.

## How do I fix CVE-2025-62705?

Upgrade github.com/openbao/openbao to 0.0.0-20251022165510-cc2c476bac66 or later.

## Is CVE-2025-62705 being exploited?

There is no known exploitation of CVE-2025-62705 in the wild and no public exploit code.

## Other vulnerabilities in openbao

- [CVE-2026-33757](https://insights.sbomify.com/CVE-2026-33757/): OpenBao lacks user confirmation for OIDC direct callback mode (critical 9.6)
- [CVE-2026-33758](https://insights.sbomify.com/CVE-2026-33758/): OpenBao has Reflected XSS in its OIDC authentication error message (critical 9.4)
- [CVE-2025-54997](https://insights.sbomify.com/CVE-2025-54997/): OpenBao: Privileged Operator May Execute Code on the Underlying Host (critical 9.1)
- [CVE-2025-64761](https://insights.sbomify.com/CVE-2025-64761/): OpenBao Privileged Operator Identity Group Root Escalation (high 7.5)
- [CVE-2025-59043](https://insights.sbomify.com/CVE-2025-59043/): OpenBao vulnerable to denial of service via malicious JSON request processing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62705 and fix it if it is affected.

What it is: CVE-2025-62705 is a medium-severity vulnerability in openbao, published on 22 Oct 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-62705 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20251022165510-cc2c476bac66
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20251022165510-cc2c476bac66
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20251022165510-cc2c476bac66
- openbao (Bitnami): affected all versions; fixed in 2.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62705/ (Markdown: https://insights.sbomify.com/CVE-2025-62705/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62705
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62705
- OSV: https://osv.dev/vulnerability/CVE-2025-62705

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62705/
Summaries are generated and may contain mistakes; the official description above is the record.
