CVE-2025-62706 Authlib : JWE zip=DEF decompression bomb enables DoS
Attackers can cause denial of service in Authlib by sending small JWE tokens that expand into huge memory usage during decompression.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-62706?
CVE-2025-62706 is a medium-severity denial of service vulnerability in authlib, published on 22 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.5, Authlib’s JWE zip=DEF path performs unbounded DEFLATE decompression. A very small ciphertext can expand into tens or hundreds of megabytes on decrypt, allowing an attacker who can supply decryptable tokens to exhaust memory and CPU and cause denial of service. This issue has been patched in version 1.6.5. Workarounds for this issue involve rejecting or stripping zip=DEF for inbound JWEs at the application boundary, forking and add a bounded decompression guard via decompressobj().decompress(data, MAX_SIZE)) and returning an error when output exceeds a safe limit, or enforcing strict maximum token sizes and fail fast on oversized inputs; combine with rate limiting.
Which versions are affected by CVE-2025-62706?
3 open source packages ship an affected version, including authlib. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
authlib PyPI | All versions | 1.6.5 |
authlib PyPI | All versions | 1.6.5 |
authlib PyPI | All versions | 1.6.5 |
Linux distribution packages (3)
python-Authlib SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 1.3.1-150600.3.9.1 |
python-Authlib SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 1.3.1-150600.3.9.1 |
python-Authlib openSUSE:Leap 15.6 | All versions | 1.3.1-150600.3.9.1 |
Products include Authlib Authlib.
How do I fix CVE-2025-62706?
Upgrade authlib to 1.6.5 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-62706 being exploited?
There is no known exploitation of CVE-2025-62706 in the wild and no public exploit code.
Other vulnerabilities in authlib
- CVE-2026-27962 Authlib JWS JWK Header Injection: Signature Verification Bypass
- CVE-2026-28490 Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle
- CVE-2026-28498 Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding
- CVE-2026-28802 Authlib: Setting `alg: none` and a blank signature appears to bypass signature verification
- CVE-2025-61920 Authlib is vulnerable to Denial of Service via Oversized JOSE Segments
Sources
Also known as DEBIAN-CVE-2025-62706, ECHO-69d4-5657-6ffb, GHSA-g7f3-828f-7h7m, PYSEC-2026-1202, ROOT-APP-PYPI-CVE-2025-62706, SUSE-SU-2025:3842-1 and 1 more.