# CVE-2025-62706: Authlib : JWE zip=DEF decompression bomb enables DoS

> Attackers can cause denial of service in Authlib by sending small JWE tokens that expand into huge memory usage during decompression.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Oct 2025
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-62706, ECHO-69d4-5657-6ffb, GHSA-g7f3-828f-7h7m, PYSEC-2026-1202, ROOT-APP-PYPI-CVE-2025-62706, SUSE-SU-2025:3842-1, UBUNTU-CVE-2025-62706

## What is CVE-2025-62706?

CVE-2025-62706 is a medium-severity denial of service vulnerability in authlib, published on 22 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.5, Authlib’s JWE zip=DEF path performs unbounded DEFLATE decompression. A very small ciphertext can expand into tens or hundreds of megabytes on decrypt, allowing an attacker who can supply decryptable tokens to exhaust memory and CPU and cause denial of service. This issue has been patched in version 1.6.5. Workarounds for this issue involve rejecting or stripping zip=DEF for inbound JWEs at the application boundary, forking and add a bounded decompression guard via decompressobj().decompress(data, MAX_SIZE)) and returning an error when output exceeds a safe limit, or enforcing strict maximum token sizes and fail fast on oversized inputs; combine with rate limiting.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-62706?

3 open source packages ship an affected version, including authlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authlib` | PyPI | All versions | 1.6.5 |
| `authlib` | PyPI | All versions | 1.6.5 |
| `authlib` | PyPI | All versions | 1.6.5 |
| `python-Authlib` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 1.3.1-150600.3.9.1 |
| `python-Authlib` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 1.3.1-150600.3.9.1 |
| `python-Authlib` | openSUSE:Leap 15.6 | All versions | 1.3.1-150600.3.9.1 |

Products: Authlib Authlib.

## How do I fix CVE-2025-62706?

Upgrade authlib to 1.6.5 or later.

## Is CVE-2025-62706 being exploited?

There is no known exploitation of CVE-2025-62706 in the wild and no public exploit code.

## Other vulnerabilities in authlib

- [CVE-2026-27962](https://insights.sbomify.com/CVE-2026-27962/): Authlib JWS JWK Header Injection: Signature Verification Bypass (critical 9.1)
- [CVE-2026-28490](https://insights.sbomify.com/CVE-2026-28490/): Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle (high 8.3)
- [CVE-2026-28498](https://insights.sbomify.com/CVE-2026-28498/): Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding (high 8.2)
- [CVE-2026-28802](https://insights.sbomify.com/CVE-2026-28802/): Authlib: Setting `alg: none` and a blank signature appears to bypass signature verification (high 7.7)
- [CVE-2025-61920](https://insights.sbomify.com/CVE-2025-61920/): Authlib is vulnerable to Denial of Service via Oversized JOSE Segments (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62706 and fix it if it is affected.

What it is: CVE-2025-62706 is a medium-severity denial of service vulnerability in authlib, published on 22 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62706 in the wild and no public exploit code.

Affected packages and fixed versions:
- authlib (PyPI): affected all versions; fixed in 1.6.5
- authlib (PyPI): affected all versions; fixed in 1.6.5
- authlib (PyPI): affected all versions; fixed in 1.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62706/ (Markdown: https://insights.sbomify.com/CVE-2025-62706/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62706
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62706
- OSV: https://osv.dev/vulnerability/CVE-2025-62706

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62706/
Summaries are generated and may contain mistakes; the official description above is the record.
