{"answers":{"affected":"2 open source packages ship an affected version, including @kottster/server.","exploited":"There is no known exploitation of CVE-2025-62713 in the wild and no public exploit code.","fix":"Upgrade @kottster/server to 3.3.2 or later.","what":"CVE-2025-62713 is a high-severity command injection vulnerability in kottster, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62713 and fix it if it is affected.\n\nWhat it is: CVE-2025-62713 is a high-severity command injection vulnerability in kottster, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-62713 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @kottster/server (npm): affected from 3.2.0; fixed in 3.3.2\n- @kottster/server (npm): affected from 3.2.0; fixed in 3.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62713/ (Markdown: https://insights.sbomify.com/CVE-2025-62713/index.md)","id":"CVE-2025-62713","markdown":"https://insights.sbomify.com/CVE-2025-62713/index.md","name":"CVE-2025-62713","record":{"aliases":["GHSA-j3w7-9qc3-g96p"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js admin panel","requires_auth":"none","summary":"Attackers can execute arbitrary commands via pre-authentication RCE in Kottster admin panel when running in development mode.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"Kottster is a self hosted Node.js admin panel. From versions 3.2.0 to before 3.3.2, Kottster contains a pre-authentication remote code execution (RCE) vulnerability when running in development mode. This affects development mode only, production deployments were never affected. This issue has been fixed in version 3.3.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kottster app reinitialization can be re-triggered allowing command injection in development mode","id":"CVE-2025-62713","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Karmada Dashboard API Unauthorized Access Vulnerability","id":"CVE-2025-62714"},"packages":[{"ecosystem":"npm","fixed":["3.3.2"],"introduced":["3.2.0"],"last_affected":[],"package":"@kottster/server","purl":null,"source":"GHSA-j3w7-9qc3-g96p"},{"ecosystem":"npm","fixed":["3.3.2"],"introduced":["3.2.0"],"last_affected":[],"package":"@kottster/server","purl":"pkg:npm/%40kottster/server","source":"GHSA-j3w7-9qc3-g96p"}],"prev":{"headline":"JumpServer Connection Token Leak Vulnerability","id":"CVE-2025-62712"},"products":["kottster"],"published":"2025-10-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-23","vendors":["kottster"]},"summary":"Attackers can execute arbitrary commands via pre-authentication RCE in Kottster admin panel when running in development mode.","url":"https://insights.sbomify.com/CVE-2025-62713/"}