# CVE-2025-62713: Kottster app reinitialization can be re-triggered allowing command injection in development mode

> Attackers can execute arbitrary commands via pre-authentication RCE in Kottster admin panel when running in development mode.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2025
- **Updated:** 23 Oct 2025
- **Also known as:** GHSA-j3w7-9qc3-g96p

## What is CVE-2025-62713?

CVE-2025-62713 is a high-severity command injection vulnerability in kottster, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kottster is a self hosted Node.js admin panel. From versions 3.2.0 to before 3.3.2, Kottster contains a pre-authentication remote code execution (RCE) vulnerability when running in development mode. This affects development mode only, production deployments were never affected. This issue has been fixed in version 3.3.2.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-62713?

2 open source packages ship an affected version, including @kottster/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@kottster/server` | npm | From 3.2.0 | 3.3.2 |
| `@kottster/server` | npm | From 3.2.0 | 3.3.2 |

## How do I fix CVE-2025-62713?

Upgrade @kottster/server to 3.3.2 or later.

## Is CVE-2025-62713 being exploited?

There is no known exploitation of CVE-2025-62713 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62713 and fix it if it is affected.

What it is: CVE-2025-62713 is a high-severity command injection vulnerability in kottster, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62713 in the wild and no public exploit code.

Affected packages and fixed versions:
- @kottster/server (npm): affected from 3.2.0; fixed in 3.3.2
- @kottster/server (npm): affected from 3.2.0; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62713/ (Markdown: https://insights.sbomify.com/CVE-2025-62713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62713
- OSV: https://osv.dev/vulnerability/CVE-2025-62713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62713/
Summaries are generated and may contain mistakes; the official description above is the record.
