{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62716 exists.","fix":"No fix has been published for CVE-2025-62716 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-62716 is a high-severity cross-site scripting vulnerability in makeplane plane, published on 24 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-62716 and fix it if it is affected.\n\nWhat it is: CVE-2025-62716 is a high-severity cross-site scripting vulnerability in makeplane plane, published on 24 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62716 exists.\n\nAffected product: makeplane plane. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62716/ (Markdown: https://insights.sbomify.com/CVE-2025-62716/index.md)","id":"CVE-2025-62716","markdown":"https://insights.sbomify.com/CVE-2025-62716/index.md","name":"CVE-2025-62716","record":{"aliases":["GHSA-6fj7-xgpg-mj6f"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Plane project management","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via an open redirect in the next_path parameter, leading to privilege escalation and data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"Plane is open-source project management software. Prior to version 1.1.0, an open redirect vulnerability in the ?next_path query parameter allows attackers to supply arbitrary schemes (e.g., javascript:) that are passed directly to router.push. This results in a cross-site scripting (XSS) vulnerability, enabling attackers to execute arbitrary JavaScript in the victim’s browser. The issue can be exploited without authentication and has severe impact, including information disclosure, and privilege escalation and modifications of administrative settings. This issue has been patched in version 1.1.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Plane Vulnerable to Cross-Site Scripting via Open Redirect in ?next_path Parameter","id":"CVE-2025-62716","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"Emlog Pro session verification code error due to clearing logic error","id":"CVE-2025-62717"},"packages":[],"prev":{"headline":"ClipBucket v5: Stored XSS via Collection Tags","id":"CVE-2025-62715"},"products":["plane"],"published":"2025-10-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-24","vendors":["makeplane"]},"summary":"Attackers can execute arbitrary JavaScript via an open redirect in the next_path parameter, leading to privilege escalation and data theft.","url":"https://insights.sbomify.com/CVE-2025-62716/"}