# CVE-2025-62718: Axios has a NO_PROXY Hostname Normalization Bypass that Leads to SSRF

> Attackers can bypass NO_PROXY rules via hostname normalization flaws to access internal services through a proxy, requiring an upgrade to Axios.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 10 Sep 2026
- **Also known as:** CLEANSTART-2026-FC62060, CLEANSTART-2026-PQ32851, DEBIAN-CVE-2025-62718, ECHO-eb65-3dc1-4753, GHSA-3p68-rc4w-qgx5, MINI-2334-99r5-4q39, MINI-33fj-pqqw-8c2w, MINI-5hc8-xcr5-9267, MINI-5hvh-gxx9-rp6q, MINI-6fw9-hv3h-9wpp, MINI-7wvg-j4gh-rqj9, MINI-867m-7jxm-p9vr, MINI-9r35-c8pj-7r36, MINI-c62v-v9wq-4cg9, MINI-f5pr-4gg6-j427, MINI-f642-5crf-9x6q, MINI-g969-q7cp-q265, MINI-h6ph-mhw5-hmmg, MINI-mvr7-g34g-cr89, MINI-mwjq-jx56-g99q, MINI-pff8-73c7-x2hf, MINI-v794-fjww-447v, MINI-v8c6-r58g-53hq, MINI-xq8p-f79c-42g7, ROOT-APP-NPM-CVE-2025-62718, UBUNTU-CVE-2025-62718

## What is CVE-2025-62718?

CVE-2025-62718 is a medium-severity server-side request forgery vulnerability in axios, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Axios is a promise based HTTP client for the browser and Node.js. Prior to 1.15.0 and 0.31.0, Axios does not correctly handle hostname normalization when checking NO_PROXY rules. Requests to loopback addresses like localhost. (with a trailing dot) or [::1] (IPv6 literal) skip NO_PROXY matching and go through the configured proxy. This goes against what developers expect and lets attackers force requests through a proxy, even if NO_PROXY is set up to protect loopback or internal services. This issue leads to the possibility of proxy bypass and SSRF vulnerabilities allowing attackers to reach sensitive loopback or internal services despite the configured protections. This vulnerability is fixed in 1.15.0 and 0.31.0.

Weakness: CWE-1289 (Improper Validation of Unsafe Equivalence in Input), CWE-918 (Server-Side Request Forgery), CWE-441 (Unintended Proxy or Intermediary)

## Which versions are affected by CVE-2025-62718?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | All versions | 0.31.0 |
| `axios` | npm | All versions | 0.31.0 |
| `axios` | npm | From 1.0.0 | 1.15.0 |
| `axios` | npm | From 1.0.0 | 1.15.0 |

Products: Axios Axios.

## How do I fix CVE-2025-62718?

Upgrade axios to a fixed version for your release line: 0.31.0 or 1.15.0.

## Is CVE-2025-62718 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62718 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62718 and fix it if it is affected.

What it is: CVE-2025-62718 is a medium-severity server-side request forgery vulnerability in axios, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62718 exists.

Affected packages and fixed versions:
- axios (npm): affected all versions; fixed in 0.31.0
- axios (npm): affected all versions; fixed in 0.31.0
- axios (npm): affected from 1.0.0; fixed in 1.15.0
- axios (npm): affected from 1.0.0; fixed in 1.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62718/ (Markdown: https://insights.sbomify.com/CVE-2025-62718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62718
- OSV: https://osv.dev/vulnerability/CVE-2025-62718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62718/
Summaries are generated and may contain mistakes; the official description above is the record.
