# CVE-2025-62726: n8n Vulnerable to Remote Code Execution via Git Node Pre-Commit Hook

> Attackers can execute arbitrary code in n8n by triggering malicious Git pre-commit hooks via the Git Node component.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Oct 2025
- **Updated:** 31 Oct 2025
- **Also known as:** GHSA-xgp7-7qjq-vg47

## What is CVE-2025-62726?

CVE-2025-62726 is a high-severity code injection vulnerability in N8n N8n, published on 30 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to 1.113.0, a remote code execution vulnerability exists in the Git Node component available in both Cloud and Self-Hosted versions of n8n. When a malicious actor clones a remote repository containing a pre-commit hook, the subsequent use of the Commit operation in the Git Node can inadvertently trigger the hook’s execution. This allows attackers to execute arbitrary code within the n8n environment, potentially compromising the system and any connected credentials or workflows. This vulnerability is fixed in 1.113.0.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2025-62726?

2 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.113.0 |
| `n8n` | npm | All versions | 1.113.0 |

Products: N8n N8n.

## How do I fix CVE-2025-62726?

Upgrade n8n to 1.113.0 or later.

## Is CVE-2025-62726 being exploited?

There is no known exploitation of CVE-2025-62726 in the wild and no public exploit code.

Public exploit code:

- This is a proof-of-concept demonstration for CVE-2025-62726, created for educational purposes as part of a class project. Part of CMU Course : 18-739 Hacking & Offensive Security in Fall 2025 (github_poc): https://github.com/baktistr/cve-2025-62726-poc
- cve-2025-62726-malicious-repo (github_poc): https://github.com/Muzyli/cve-2025-62726-malicious-repo

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62726 and fix it if it is affected.

What it is: CVE-2025-62726 is a high-severity code injection vulnerability in N8n N8n, published on 30 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62726 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.113.0
- n8n (npm): affected all versions; fixed in 1.113.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62726/ (Markdown: https://insights.sbomify.com/CVE-2025-62726/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62726
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62726
- OSV: https://osv.dev/vulnerability/CVE-2025-62726

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62726/
Summaries are generated and may contain mistakes; the official description above is the record.
