CVE-2025-62728 Apache Hive: SQL injection vulnerability when processing delete column statistics requests via the HMS Thrift APIs

Medium 5.4 Published Updated

Authorized users can execute arbitrary SQL via Hive Metastore Thrift APIs, requiring direct API access or specific configuration.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-62728?

CVE-2025-62728 is a medium-severity SQL injection vulnerability in Apache Hive, published on 26 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

SQL injection vulnerability in Hive Metastore Server (HMS) when processing delete column statistics requests via the Thrift APIs. The vulnerability is only exploitable by trusted/authorized users/applications that are allowed to call directly the Thrift APIs. In most real-world deployments, HMS is accessible to only a handful of applications (e.g., Hiveserver2) thus the vulnerability is not exploitable. Moreover, the vulnerable code cannot be reached when metastore.try.direct.sql property is set to false.

This issue affects Apache Hive: from 4.1.0 before 4.2.0.

Users are recommended to upgrade to version 4.2.0, which fixes the issue. Users who cannot upgrade directly are encouraged to set metastore.try.direct.sql property to false if the HMS Thrift APIs are exposed to general public.

Weakness: CWE-89

Which versions are affected by CVE-2025-62728?

4 open source packages ship an affected version, including org.apache.hive:hive-common and org.apache.hive:hive-metastore. It affects 1 product.

PackageAffectedFixed in
org.apache.hive:hive-common MavenFrom 4.1.04.2.0
org.apache.hive:hive-common MavenFrom 4.1.04.2.0
org.apache.hive:hive-metastore MavenFrom 4.1.04.2.0
org.apache.hive:hive-metastore MavenFrom 4.1.04.2.0

Products include Apache Hive.

How do I fix CVE-2025-62728?

Upgrade org.apache.hive:hive-common to 4.2.0 or later.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2025-62728 being exploited?

There is no known exploitation of CVE-2025-62728 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-ST63902, GHSA-932v-x9x2-vq29.

Is CVE-2025-62728 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free