# CVE-2025-62780: changedetection.io vulnerable to stored XSS in Watch update via API

> Attackers can inject malicious JavaScript via the Watch update API, leading to stored XSS execution when users preview the watch.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Nov 2025
- **Updated:** 10 Nov 2025
- **Also known as:** GHSA-4c3j-3h7v-22q9, PYSEC-2025-91

## What is CVE-2025-62780?

CVE-2025-62780 is a low-severity cross-site scripting vulnerability in dgtlmoon changedetection.io, published on 10 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

changedetection.io is a free open source web page change detection tool. A Stored Cross Site Scripting is present in changedetection.io Watch update API in versions prior to 0.50.34 due to insufficient security checks. Two scenarios are possible. In the first, an attacker can insert a new watch with an arbitrary URL which really points to a web page. Once the HTML content is retrieved, the attacker updates the URL with a JavaScript payload. In the second, an attacker substitutes the URL in an existing watch with a new URL that is in reality a JavaScript payload. When the user clicks on *Preview* and then on the malicious link, the JavaScript malicious code is executed. Version 0.50.34 fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-62780?

3 open source packages ship an affected version, including changedetection.io and changedetection-io. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `changedetection.io` | PyPI | All versions | 0.50.34 |
| `changedetection-io` | PyPI | All versions | 0.50.34 |
| `changedetection-io` | PyPI | All versions | 0.50.34 |

Products: Changedetection Changedetection.

## How do I fix CVE-2025-62780?

Upgrade changedetection.io to 0.50.34 or later.

## Is CVE-2025-62780 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62780 exists.

Public exploit code:

- ChangeDetection.io <= v0.50.33 - Stored XSS via Watch API (nuclei): http/cves/2025/CVE-2025-62780.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62780 and fix it if it is affected.

What it is: CVE-2025-62780 is a low-severity cross-site scripting vulnerability in dgtlmoon changedetection.io, published on 10 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62780 exists.

Affected packages and fixed versions:
- changedetection.io (PyPI): affected all versions; fixed in 0.50.34
- changedetection-io (PyPI): affected all versions; fixed in 0.50.34
- changedetection-io (PyPI): affected all versions; fixed in 0.50.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62780/ (Markdown: https://insights.sbomify.com/CVE-2025-62780/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62780
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62780
- OSV: https://osv.dev/vulnerability/CVE-2025-62780

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62780/
Summaries are generated and may contain mistakes; the official description above is the record.
