CVE-2025-6279 Upsonic Pickle add_tool cloudpickle.loads deserialization

Medium 5.1 Published Updated

Upsonic library allows remote code execution via unsafe cloudpickle deserialization in the add_tool function, requiring an upgrade to a patched version.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-6279?

CVE-2025-6279 is a medium-severity unsafe deserialization vulnerability in Upsonic, published on 19 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability, which was classified as critical, has been found in Upsonic up to 0.55.6. This issue affects the function cloudpickle.loads of the file /tools/add_tool of the component Pickle Handler. The manipulation leads to deserialization. The exploit has been disclosed to the public and may be used.

Weakness: CWE-502, CWE-20

Which versions are affected by CVE-2025-6279?

3 open source packages ship an affected version, including upsonic. It affects 1 product.

PackageAffectedFixed in
upsonic PyPIAll versions0.56.0
upsonic PyPIAll versions0.56.0
upsonic PyPIAll versions0.56.0

Products include Upsonic Upsonic.

How do I fix CVE-2025-6279?

Upgrade upsonic to 0.56.0 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-6279 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6279 exists.

Sources

Also known as GHSA-rpfv-46xj-5984, PYSEC-2025-68.

Is CVE-2025-6279 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free