{"answers":{"affected":"3 open source packages ship an affected version, including upsonic. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6279 exists.","fix":"Upgrade upsonic to 0.56.0 or later.","what":"CVE-2025-6279 is a medium-severity unsafe deserialization vulnerability in Upsonic, published on 19 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-6279 and fix it if it is affected.\n\nWhat it is: CVE-2025-6279 is a medium-severity unsafe deserialization vulnerability in Upsonic, published on 19 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6279 exists.\n\nAffected packages and fixed versions:\n- upsonic (PyPI): affected all versions; fixed in 0.56.0\n- upsonic (PyPI): affected all versions; fixed in 0.56.0\n- upsonic (PyPI): affected all versions; fixed in 0.56.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-6279/ (Markdown: https://insights.sbomify.com/CVE-2025-6279/index.md)","id":"CVE-2025-6279","markdown":"https://insights.sbomify.com/CVE-2025-6279/index.md","name":"CVE-2025-6279","record":{"aliases":["GHSA-rpfv-46xj-5984","PYSEC-2025-68"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python AI agent library","requires_auth":"low_privilege","summary":"Upsonic library allows remote code execution via unsafe cloudpickle deserialization in the add_tool function, requiring an upgrade to a patched version.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"upsonic","vendor":"upsonic"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A vulnerability, which was classified as critical, has been found in Upsonic up to 0.55.6. This issue affects the function cloudpickle.loads of the file /tools/add_tool of the component Pickle Handler. The manipulation leads to deserialization. The exploit has been disclosed to the public and may be used.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Upsonic Pickle add_tool cloudpickle.loads deserialization","id":"CVE-2025-6279","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":4,"next":{"headline":"TransformerOptimus SuperAGI EmailToolKit read_email.py download_attachment path traversal","id":"CVE-2025-6280"},"packages":[{"ecosystem":"PyPI","fixed":["0.56.0"],"introduced":["0"],"last_affected":[],"package":"upsonic","purl":null,"source":"GHSA-rpfv-46xj-5984"},{"ecosystem":"PyPI","fixed":["0.56.0"],"introduced":["0"],"last_affected":[],"package":"upsonic","purl":"pkg:pypi/upsonic","source":"GHSA-rpfv-46xj-5984"},{"ecosystem":"PyPI","fixed":["0.56.0"],"introduced":["0"],"last_affected":[],"package":"upsonic","purl":"pkg:pypi/upsonic","source":"PYSEC-2025-68"}],"prev":{"headline":"Upsonic server.py os.path.join path traversal","id":"CVE-2025-6278"},"products":["Upsonic"],"published":"2025-06-19","related":[{"cvss_score":5.1,"headline":"Upsonic server.py os.path.join path traversal","id":"CVE-2025-6278","kev_date_added":null,"published":"2025-06-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-23","vendors":["n/a"]},"summary":"Upsonic library allows remote code execution via unsafe cloudpickle deserialization in the add_tool function, requiring an upgrade to a patched version.","url":"https://insights.sbomify.com/CVE-2025-6279/"}