# CVE-2025-6279: Upsonic Pickle add_tool cloudpickle.loads deserialization

> Upsonic library allows remote code execution via unsafe cloudpickle deserialization in the add_tool function, requiring an upgrade to a patched version.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2025
- **Updated:** 23 Jun 2025
- **Also known as:** GHSA-rpfv-46xj-5984, PYSEC-2025-68

## What is CVE-2025-6279?

CVE-2025-6279 is a medium-severity unsafe deserialization vulnerability in Upsonic, published on 19 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, has been found in Upsonic up to 0.55.6. This issue affects the function cloudpickle.loads of the file /tools/add_tool of the component Pickle Handler. The manipulation leads to deserialization. The exploit has been disclosed to the public and may be used.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-6279?

3 open source packages ship an affected version, including upsonic. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `upsonic` | PyPI | All versions | 0.56.0 |
| `upsonic` | PyPI | All versions | 0.56.0 |
| `upsonic` | PyPI | All versions | 0.56.0 |

Products: Upsonic Upsonic.

## How do I fix CVE-2025-6279?

Upgrade upsonic to 0.56.0 or later.

## Is CVE-2025-6279 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6279 exists.

## Other vulnerabilities in Upsonic

- [CVE-2025-6278](https://insights.sbomify.com/CVE-2025-6278/): Upsonic server.py os.path.join path traversal (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6279 and fix it if it is affected.

What it is: CVE-2025-6279 is a medium-severity unsafe deserialization vulnerability in Upsonic, published on 19 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6279 exists.

Affected packages and fixed versions:
- upsonic (PyPI): affected all versions; fixed in 0.56.0
- upsonic (PyPI): affected all versions; fixed in 0.56.0
- upsonic (PyPI): affected all versions; fixed in 0.56.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6279/ (Markdown: https://insights.sbomify.com/CVE-2025-6279/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6279
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6279
- OSV: https://osv.dev/vulnerability/CVE-2025-6279

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6279/
Summaries are generated and may contain mistakes; the official description above is the record.
