# CVE-2025-62794: GitHub Workflow Updater stored the optional Github token in plaintext

> An attacker with local file access can read plaintext GitHub tokens stored by the extension, potentially leading to account takeover.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Oct 2025
- **Updated:** 29 Oct 2025
- **Also known as:** GHSA-679x-97jw-8vjp

## What is CVE-2025-62794?

CVE-2025-62794 is a low-severity vulnerability in RichardoC github-workflow-updater-extension, published on 28 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

GitHub Workflow Updater is a VS Code extension that automatically pins GitHub Actions to specific commits for enhanced security. Before 0.0.7, any provided Github token would be stored in plaintext in the editor configuration as json on disk, rather than through the more secure "securestorage" api. An attacker with read only access to your home directory could have read this token and used it to perform actions with that token. Update to 0.0.7.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2025-62794?


## How do I fix CVE-2025-62794?

No fix has been published for CVE-2025-62794 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-62794 being exploited?

There is no known exploitation of CVE-2025-62794 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62794 and fix it if it is affected.

What it is: CVE-2025-62794 is a low-severity vulnerability in RichardoC github-workflow-updater-extension, published on 28 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62794 in the wild and no public exploit code.

Affected product: RichardoC github-workflow-updater-extension. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62794/ (Markdown: https://insights.sbomify.com/CVE-2025-62794/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62794
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62794
- OSV: https://osv.dev/vulnerability/CVE-2025-62794

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62794/
Summaries are generated and may contain mistakes; the official description above is the record.
