{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62795 exists.","fix":"No fix has been published for CVE-2025-62795 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-62795 is a high-severity missing authorization vulnerability in jumpserver, published on 30 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62795 and fix it if it is affected.\n\nWhat it is: CVE-2025-62795 is a high-severity missing authorization vulnerability in jumpserver, published on 30 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62795 exists.\n\nAffected product: jumpserver. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62795/ (Markdown: https://insights.sbomify.com/CVE-2025-62795/index.md)","id":"CVE-2025-62795","markdown":"https://insights.sbomify.com/CVE-2025-62795/index.md","name":"CVE-2025-62795","record":{"aliases":["GHSA-7893-256g-m822"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"JumpServer bastion host","requires_auth":"low_privilege","summary":"Low-privileged users can bypass authorization to access LDAP configurations and trigger synchronization via WebSocket, potentially exposing credentials.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jumpserver","vendor":"fit2cloud"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to v3.10.21-lts and v4.10.12-lts, a low-privileged authenticated user can invoke LDAP configuration tests and start LDAP synchronization by sending crafted messages to the /ws/ldap/ WebSocket endpoint, bypassing authorization checks and potentially exposing LDAP credentials or causing unintended sync operations. This vulnerability is fixed in v3.10.21-lts and v4.10.12-lts.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"JumpServer Unauthorized LDAP Configuration Access via WebSocket","id":"CVE-2025-62795","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"PrivateBin persistent HTML injection in attachment filename enables redirect and defacement","id":"CVE-2025-62796"},"packages":[],"prev":{"headline":"GitHub Workflow Updater stored the optional Github token in plaintext","id":"CVE-2025-62794"},"products":["jumpserver"],"published":"2025-10-30","related":[{"cvss_score":10,"headline":"Arbitrary File Read in Ansible Playbooks in Jumpserver","id":"CVE-2024-40628","kev_date_added":null,"published":"2024-07-18"},{"cvss_score":10,"headline":"Arbitrary File Write in Ansible Playbooks leads to RCE in Jumpserver","id":"CVE-2024-40629","kev_date_added":null,"published":"2024-07-18"},{"cvss_score":10,"headline":"JumpServer's insecure Ansible playbook validation leads to RCE in Celery","id":"CVE-2024-29201","kev_date_added":null,"published":"2024-03-29"},{"cvss_score":10,"headline":"JumpServer vulnerable to Jinja2 template injection in Ansible leads to RCE in Celery","id":"CVE-2024-29202","kev_date_added":null,"published":"2024-03-29"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2023-48193","kev_date_added":null,"published":"2023-11-28"},{"cvss_score":9.6,"headline":"JumpServer Connection Token Leak Vulnerability","id":"CVE-2025-62712","kev_date_added":null,"published":"2025-10-30"},{"cvss_score":8.9,"headline":"Path traversal in Jumpserver","id":"CVE-2023-42819","kev_date_added":null,"published":"2023-09-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-31","vendors":["jumpserver"]},"summary":"Low-privileged users can bypass authorization to access LDAP configurations and trigger synchronization via WebSocket, potentially exposing credentials.","url":"https://insights.sbomify.com/CVE-2025-62795/"}