# CVE-2025-62795: JumpServer Unauthorized LDAP Configuration Access via WebSocket

> Low-privileged users can bypass authorization to access LDAP configurations and trigger synchronization via WebSocket, potentially exposing credentials.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Oct 2025
- **Updated:** 31 Oct 2025
- **Also known as:** GHSA-7893-256g-m822

## What is CVE-2025-62795?

CVE-2025-62795 is a high-severity missing authorization vulnerability in jumpserver, published on 30 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to v3.10.21-lts and v4.10.12-lts, a low-privileged authenticated user can invoke LDAP configuration tests and start LDAP synchronization by sending crafted messages to the /ws/ldap/ WebSocket endpoint, bypassing authorization checks and potentially exposing LDAP credentials or causing unintended sync operations. This vulnerability is fixed in v3.10.21-lts and v4.10.12-lts.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-62795?

It affects 1 product.


Products: Fit2cloud Jumpserver.

## How do I fix CVE-2025-62795?

No fix has been published for CVE-2025-62795 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-62795 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62795 exists.

## Other vulnerabilities in jumpserver

- [CVE-2024-40628](https://insights.sbomify.com/CVE-2024-40628/): Arbitrary File Read in Ansible Playbooks in Jumpserver (critical 10.0)
- [CVE-2024-40629](https://insights.sbomify.com/CVE-2024-40629/): Arbitrary File Write in Ansible Playbooks leads to RCE in Jumpserver (critical 10.0)
- [CVE-2024-29201](https://insights.sbomify.com/CVE-2024-29201/): JumpServer's insecure Ansible playbook validation leads to RCE in Celery (critical 10.0)
- [CVE-2024-29202](https://insights.sbomify.com/CVE-2024-29202/): JumpServer vulnerable to Jinja2 template injection in Ansible leads to RCE in Celery (critical 10.0)
- [CVE-2023-48193](https://insights.sbomify.com/CVE-2023-48193/): Security feature bypass in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62795 and fix it if it is affected.

What it is: CVE-2025-62795 is a high-severity missing authorization vulnerability in jumpserver, published on 30 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62795 exists.

Affected product: jumpserver. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62795/ (Markdown: https://insights.sbomify.com/CVE-2025-62795/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62795
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62795
- OSV: https://osv.dev/vulnerability/CVE-2025-62795

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62795/
Summaries are generated and may contain mistakes; the official description above is the record.
