{"answers":{"affected":"2 open source packages ship an affected version, including code16/sharp.","exploited":"There is no known exploitation of CVE-2025-62798 in the wild and no public exploit code.","fix":"Upgrade code16/sharp to 9.11.1 or later.","what":"CVE-2025-62798 is a medium-severity cross-site scripting vulnerability in code16 sharp, published on 28 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-62798 and fix it if it is affected.\n\nWhat it is: CVE-2025-62798 is a medium-severity cross-site scripting vulnerability in code16 sharp, published on 28 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-62798 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- code16/sharp (Packagist): affected all versions; fixed in 9.11.1\n- code16/sharp (Packagist): affected all versions; fixed in 9.11.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62798/ (Markdown: https://insights.sbomify.com/CVE-2025-62798/index.md)","id":"CVE-2025-62798","markdown":"https://insights.sbomify.com/CVE-2025-62798/index.md","name":"CVE-2025-62798","record":{"aliases":["GHSA-9f58-4465-23c7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel CMS framework","requires_auth":"low_privilege","summary":"Attackers can inject arbitrary JavaScript via Vue template syntax in SharpShowTextField, leading to XSS in the browser.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Sharp is a content management framework built for Laravel as a package. Prior to 9.11.1, a Cross-Site Scripting (XSS) vulnerability was discovered in code16/sharp when rendering content using the SharpShowTextField component. In affected versions, expressions wrapped in {{ \u0026 }} were evaluated by Vue. This allowed attackers to inject arbitrary JavaScript or HTML that executes in the browser when the field is displayed. The issue has been fixed in v9.11.1 .","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sharp user-provided input can be evaluated in a SharpShowTextField with Vue template syntax","id":"CVE-2025-62798","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"FastDDS's heap buffer overflow in RTPS DATA_FRAG enables unauthenticated DoS (potential RCE)","id":"CVE-2025-62799"},"packages":[{"ecosystem":"Packagist","fixed":["9.11.1"],"introduced":["0"],"last_affected":[],"package":"code16/sharp","purl":null,"source":"GHSA-9f58-4465-23c7"},{"ecosystem":"Packagist","fixed":["9.11.1"],"introduced":["0"],"last_affected":[],"package":"code16/sharp","purl":"pkg:composer/code16/sharp","source":"GHSA-9f58-4465-23c7"}],"prev":{"headline":"CSRF in FluxCP account endpoints allows account takeover / state-changing actions","id":"CVE-2025-62797"},"products":["sharp"],"published":"2025-10-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-29","vendors":["code16"]},"summary":"Attackers can inject arbitrary JavaScript via Vue template syntax in SharpShowTextField, leading to XSS in the browser.","url":"https://insights.sbomify.com/CVE-2025-62798/"}