# CVE-2025-62798: Sharp user-provided input can be evaluated in a SharpShowTextField with Vue template syntax

> Attackers can inject arbitrary JavaScript via Vue template syntax in SharpShowTextField, leading to XSS in the browser.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Oct 2025
- **Updated:** 29 Oct 2025
- **Also known as:** GHSA-9f58-4465-23c7

## What is CVE-2025-62798?

CVE-2025-62798 is a medium-severity cross-site scripting vulnerability in code16 sharp, published on 28 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Sharp is a content management framework built for Laravel as a package. Prior to 9.11.1, a Cross-Site Scripting (XSS) vulnerability was discovered in code16/sharp when rendering content using the SharpShowTextField component. In affected versions, expressions wrapped in {{ & }} were evaluated by Vue. This allowed attackers to inject arbitrary JavaScript or HTML that executes in the browser when the field is displayed. The issue has been fixed in v9.11.1 .

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-62798?

2 open source packages ship an affected version, including code16/sharp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code16/sharp` | Packagist | All versions | 9.11.1 |
| `code16/sharp` | Packagist | All versions | 9.11.1 |

## How do I fix CVE-2025-62798?

Upgrade code16/sharp to 9.11.1 or later.

## Is CVE-2025-62798 being exploited?

There is no known exploitation of CVE-2025-62798 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62798 and fix it if it is affected.

What it is: CVE-2025-62798 is a medium-severity cross-site scripting vulnerability in code16 sharp, published on 28 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-62798 in the wild and no public exploit code.

Affected packages and fixed versions:
- code16/sharp (Packagist): affected all versions; fixed in 9.11.1
- code16/sharp (Packagist): affected all versions; fixed in 9.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62798/ (Markdown: https://insights.sbomify.com/CVE-2025-62798/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62798
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62798
- OSV: https://osv.dev/vulnerability/CVE-2025-62798

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62798/
Summaries are generated and may contain mistakes; the official description above is the record.
