{"answers":{"affected":"3 open source packages ship an affected version, including fastmcp. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62800 exists.","fix":"Upgrade fastmcp to 2.13.0 or later.","what":"CVE-2025-62800 is a medium-severity cross-site scripting vulnerability in jlowin fastmcp, published on 28 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-62800 and fix it if it is affected.\n\nWhat it is: CVE-2025-62800 is a medium-severity cross-site scripting vulnerability in jlowin fastmcp, published on 28 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62800 exists.\n\nAffected packages and fixed versions:\n- fastmcp (PyPI): affected all versions; fixed in 2.13.0\n- fastmcp (PyPI): affected all versions; fixed in 2.13.0\n- fastmcp (PyPI): affected all versions; fixed in 2.13.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62800/ (Markdown: https://insights.sbomify.com/CVE-2025-62800/index.md)","id":"CVE-2025-62800","markdown":"https://insights.sbomify.com/CVE-2025-62800/index.md","name":"CVE-2025-62800","record":{"aliases":["GHSA-mxxr-jv3v-6pgc","PYSEC-2026-1364","ROOT-APP-PYPI-CVE-2025-62800"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Python MCP framework","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in the FastMCP OAuth callback page via reflected XSS, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fastmcp","vendor":"jlowin"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0 have a reflected cross-site scripting vulnerability in the OAuth client callback page (oauth_callback.py) where unescaped user-controlled values are inserted into the generated HTML, allowing arbitrary JavaScript execution in the callback server origin. The issue is fixed in version 2.13.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"FastMCP vulnerable to reflected XSS in client's callback page","id":"CVE-2025-62800","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name","id":"CVE-2025-62801"},"packages":[{"ecosystem":"PyPI","fixed":["2.13.0"],"introduced":["0"],"last_affected":[],"package":"fastmcp","purl":null,"source":"GHSA-mxxr-jv3v-6pgc"},{"ecosystem":"PyPI","fixed":["2.13.0"],"introduced":["0"],"last_affected":[],"package":"fastmcp","purl":"pkg:pypi/fastmcp","source":"GHSA-mxxr-jv3v-6pgc"},{"ecosystem":"PyPI","fixed":["2.13.0"],"introduced":["0"],"last_affected":[],"package":"fastmcp","purl":"pkg:pypi/fastmcp","source":"PYSEC-2026-1364"}],"prev":{"headline":"FastDDS's heap buffer overflow in RTPS DATA_FRAG enables unauthenticated DoS (potential RCE)","id":"CVE-2025-62799"},"products":["fastmcp"],"published":"2025-10-28","related":[{"cvss_score":10,"headline":"FastMCP OpenAPI Provider has an SSRF \u0026 Path Traversal Vulnerability","id":"CVE-2026-32871","kev_date_added":null,"published":"2026-04-02"},{"cvss_score":8.2,"headline":"FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities","id":"CVE-2026-27124","kev_date_added":null,"published":"2026-04-03"},{"cvss_score":7.4,"headline":"FastMCP OAuth Proxy token reuse across MCP servers","id":"CVE-2025-69196","kev_date_added":null,"published":"2026-03-16"},{"cvss_score":6.7,"headline":"FastMCP has a Command Injection vulnerability - Gemini CLI","id":"CVE-2025-64340","kev_date_added":null,"published":"2026-04-03"},{"cvss_score":5.4,"headline":"FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name","id":"CVE-2025-62801","kev_date_added":null,"published":"2025-10-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-29","vendors":["jlowin"]},"summary":"Attackers can execute arbitrary JavaScript in the FastMCP OAuth callback page via reflected XSS, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2025-62800/"}