# CVE-2025-62820: Slack Nebula may accept arbitrary source IP addresses

> Slack Nebula mishandles CIDR configurations, allowing attackers to bypass source IP restrictions and access the network.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2025
- **Updated:** 23 Oct 2025
- **Also known as:** CLEANSTART-2026-KX60703, CLEANSTART-2026-PQ02087, CLEANSTART-2026-ZK17836, GHSA-x6fh-7qmf-69xh, GO-2025-4068, MINI-cw98-4w4w-c78v

## What is CVE-2025-62820?

CVE-2025-62820 is a medium-severity authentication bypass vulnerability in Slack Nebula, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Slack Nebula before 1.9.7 mishandles CIDR in some configurations and thus accepts arbitrary source IP addresses within the Nebula network.

Weakness: CWE-420 (Unprotected Alternate Channel)

## Which versions are affected by CVE-2025-62820?

3 open source packages ship an affected version, including github.com/slackhq/nebula.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/slackhq/nebula` | Go | From 1.9.4 | 1.9.7 |
| `github.com/slackhq/nebula` | Go | From 1.9.4 | 1.9.7 |
| `github.com/slackhq/nebula` | Go | From 1.9.4 | 1.9.7 |

## How do I fix CVE-2025-62820?

Upgrade github.com/slackhq/nebula to 1.9.7 or later.

## Is CVE-2025-62820 being exploited?

There is no known exploitation of CVE-2025-62820 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62820 and fix it if it is affected.

What it is: CVE-2025-62820 is a medium-severity authentication bypass vulnerability in Slack Nebula, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62820 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/slackhq/nebula (Go): affected from 1.9.4; fixed in 1.9.7
- github.com/slackhq/nebula (Go): affected from 1.9.4; fixed in 1.9.7
- github.com/slackhq/nebula (Go): affected from 1.9.4; fixed in 1.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62820/ (Markdown: https://insights.sbomify.com/CVE-2025-62820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62820
- OSV: https://osv.dev/vulnerability/CVE-2025-62820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62820/
Summaries are generated and may contain mistakes; the official description above is the record.
