{"answers":{"affected":"It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62875 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2025-62875 is a medium-severity denial of service vulnerability in openSUSE Tumbleweed, published on 20 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62875 and fix it if it is affected.\n\nWhat it is: CVE-2025-62875 is a medium-severity denial of service vulnerability in openSUSE Tumbleweed, published on 20 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62875 exists.\n\nAffected product: openSUSE Tumbleweed. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62875/ (Markdown: https://insights.sbomify.com/CVE-2025-62875/index.md)","id":"CVE-2025-62875","markdown":"https://insights.sbomify.com/CVE-2025-62875/index.md","name":"CVE-2025-62875","record":{"aliases":["DEBIAN-CVE-2025-62875","GHSA-px28-qwg7-83x2","UBUNTU-CVE-2025-62875","openSUSE-SU-2025:15700-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OpenSMTPD mail server","requires_auth":"none","summary":"Local attackers can crash the OpenSMTPD mail server via the UNIX domain socket, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"opensmtpd","vendor":"opensmtpd"},{"product":"tumbleweed","vendor":"opensuse"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-754","name":"Improper Check for Unusual or Exceptional Conditions"}],"description":"An Improper Check for Unusual or Exceptional Conditions vulnerability in OpenSMTPD allows local users to crash OpenSMTPD.\n\nThis issue affects openSUSE Tumbleweed: from ? before 7.8.0p0-1.1.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Local DoS in OpenSMTPD via UNIX domain socket smtpd.sock","id":"CVE-2025-62875","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":1,"n_references":2,"next":{"headline":"Privilege escalation in openSUSE","id":"CVE-2025-62876"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["7.8.0p0-1.1"],"introduced":["0"],"last_affected":[],"package":"OpenSMTPD","purl":"pkg:rpm/opensuse/OpenSMTPD\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15700-1"}],"prev":{"headline":"WordPress AnyComment plugin \u003c= 0.3.6 - Broken Access Control vulnerability","id":"CVE-2025-62874"},"products":["openSUSE Tumbleweed"],"published":"2025-11-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-21","vendors":["SUSE"]},"summary":"Local attackers can crash the OpenSMTPD mail server via the UNIX domain socket, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2025-62875/"}