{"answers":{"affected":"6 open source packages ship an affected version, including github.com/harvester/harvester-installer.","exploited":"There is no known exploitation of CVE-2025-62877 in the wild and no public exploit code.","fix":"Change a configuration setting.","what":"CVE-2025-62877 is a critical vulnerability in SUSE harvester, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62877 and fix it if it is affected.\n\nWhat it is: CVE-2025-62877 is a critical vulnerability in SUSE harvester, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-62877 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/harvester/harvester-installer (Go): affected from 1.5.0; no fix listed\n- github.com/harvester/harvester-installer (Go): affected from 1.5.0 up to 1.5.2; no fix listed\n- github.com/harvester/harvester-installer (Go): affected from 1.5.0 up to 1.5.2; no fix listed\n- github.com/harvester/harvester-installer (Go): affected from 1.6.0; no fix listed\n- github.com/harvester/harvester-installer (Go): affected from 1.6.0 up to 1.6.1; no fix listed\n- github.com/harvester/harvester-installer (Go): affected from 1.6.0 up to 1.6.1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62877/ (Markdown: https://insights.sbomify.com/CVE-2025-62877/index.md)","id":"CVE-2025-62877","markdown":"https://insights.sbomify.com/CVE-2025-62877/index.md","name":"CVE-2025-62877","record":{"aliases":["GHSA-6g8q-hp2j-gvwv","GO-2026-4281"],"analysis":{"component_type":"server_software","fix_type":"configuration_change","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"SUSE Harvester","requires_auth":"none","summary":"Attackers can access SSH using default credentials if the interactive installer is used instead of PXE boot, compromising cluster hosts.","user_interaction":"not_required","vuln_class":"hardcoded_credentials"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1188","name":"Initialization of a Resource with an Insecure Default"}],"description":"Projects using the SUSE Virtualization (Harvester) environment may expose the OS default ssh login password  if they are using the 1.5.x or 1.6.x interactive installer to either create a new cluster or add new hosts to an existing cluster.  The environment is not affected if the PXE boot mechanism is utilized along with the Harvester configuration setup.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Harvest may expose OS default ssh login password via SUSE Virtualization Interactive Installer","id":"CVE-2025-62877","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"hardcoded_credentials","year":"2025"},"n_packages":6,"n_references":2,"next":{"headline":"Local Path Provisioner vulnerable to Path Traversal via parameters.pathPattern","id":"CVE-2025-62878"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["1.5.0"],"last_affected":[],"package":"github.com/harvester/harvester-installer","purl":"pkg:golang/github.com/harvester/harvester-installer","source":"GO-2026-4281"},{"ecosystem":"Go","fixed":[],"introduced":["1.5.0"],"last_affected":["1.5.2"],"package":"github.com/harvester/harvester-installer","purl":null,"source":"GHSA-6g8q-hp2j-gvwv"},{"ecosystem":"Go","fixed":[],"introduced":["1.5.0"],"last_affected":["1.5.2"],"package":"github.com/harvester/harvester-installer","purl":"pkg:golang/github.com/harvester/harvester-installer","source":"GHSA-6g8q-hp2j-gvwv"},{"ecosystem":"Go","fixed":[],"introduced":["1.6.0"],"last_affected":[],"package":"github.com/harvester/harvester-installer","purl":"pkg:golang/github.com/harvester/harvester-installer","source":"GO-2026-4281"},{"ecosystem":"Go","fixed":[],"introduced":["1.6.0"],"last_affected":["1.6.1"],"package":"github.com/harvester/harvester-installer","purl":null,"source":"GHSA-6g8q-hp2j-gvwv"},{"ecosystem":"Go","fixed":[],"introduced":["1.6.0"],"last_affected":["1.6.1"],"package":"github.com/harvester/harvester-installer","purl":"pkg:golang/github.com/harvester/harvester-installer","source":"GHSA-6g8q-hp2j-gvwv"}],"prev":{"headline":"Privilege escalation in openSUSE","id":"CVE-2025-62876"},"products":["harvester"],"published":"2026-01-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-08","vendors":["SUSE"]},"summary":"Attackers can access SSH using default credentials if the interactive installer is used instead of PXE boot, compromising cluster hosts.","url":"https://insights.sbomify.com/CVE-2025-62877/"}