CVE-2025-63681 open-webui is Vulnerable to Incorrect Access Control

Medium 4.3 Published Updated

Attackers can stop arbitrary LLM response tasks by accessing an API endpoint without ownership verification, causing service disruption.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-63681?

CVE-2025-63681 is a medium-severity missing authorization vulnerability in Openwebui Open Webui, published on 4 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

open-webui v0.6.33 is vulnerable to Incorrect Access Control. The API /api/tasks/stop/ directly accesses and cancels tasks without verifying user ownership, enabling attackers (a normal user) to stop arbitrary LLM response tasks.

Weakness: CWE-284

Which versions are affected by CVE-2025-63681?

3 open source packages ship an affected version, including open-webui. It affects 1 product.

PackageAffectedFixed in
open-webui PyPIAll versions to 0.6.33None
open-webui PyPIAll versions to 0.6.33None
open-webui PyPIAll versions0.9.0

Products include Openwebui Open Webui.

How do I fix CVE-2025-63681?

Upgrade open-webui to 0.9.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-63681 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-63681 exists.

All Openwebui Open Webui vulnerabilities

Sources

Also known as GHSA-frv8-gffc-37px, PYSEC-2026-1732.

Is CVE-2025-63681 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free