# CVE-2025-63681: open-webui is Vulnerable to Incorrect Access Control

> Attackers can stop arbitrary LLM response tasks by accessing an API endpoint without ownership verification, causing service disruption.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** GHSA-frv8-gffc-37px, PYSEC-2026-1732

## What is CVE-2025-63681?

CVE-2025-63681 is a medium-severity missing authorization vulnerability in Openwebui Open Webui, published on 4 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

open-webui v0.6.33 is vulnerable to Incorrect Access Control. The API /api/tasks/stop/ directly accesses and cancels tasks without verifying user ownership, enabling attackers (a normal user) to stop arbitrary LLM response tasks.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-63681?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions to 0.6.33 | None |
| `open-webui` | PyPI | All versions to 0.6.33 | None |
| `open-webui` | PyPI | All versions | 0.9.0 |

Products: Openwebui Open Webui.

## How do I fix CVE-2025-63681?

Upgrade open-webui to 0.9.0 or later.

## Is CVE-2025-63681 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-63681 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-63681 and fix it if it is affected.

What it is: CVE-2025-63681 is a medium-severity missing authorization vulnerability in Openwebui Open Webui, published on 4 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-63681 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions up to 0.6.33; no fix listed
- open-webui (PyPI): affected all versions up to 0.6.33; no fix listed
- open-webui (PyPI): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-63681/ (Markdown: https://insights.sbomify.com/CVE-2025-63681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-63681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-63681
- OSV: https://osv.dev/vulnerability/CVE-2025-63681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-63681/
Summaries are generated and may contain mistakes; the official description above is the record.
