# CVE-2025-6375: poco MultipartReader.cpp MultipartInputStream null pointer dereference


- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Jun 2025
- **Updated:** 23 Jun 2025
- **Also known as:** DEBIAN-CVE-2025-6375, GHSA-xwcq-qmxg-r8f4, OESA-2026-4089, OESA-2026-4090, OESA-2026-4091, UBUNTU-CVE-2025-6375

## What is CVE-2025-6375?

CVE-2025-6375 is a medium-severity vulnerability in poco, published on 21 Jun 2025. 

### Official description

A vulnerability was found in poco up to 1.14.1. It has been rated as problematic. Affected by this issue is the function MultipartInputStream of the file Net/src/MultipartReader.cpp. The manipulation leads to null pointer dereference. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 1.14.2 is able to address this issue. The patch is identified as 6f2f85913c191ab9ddfb8fae781f5d66afccf3bf. It is recommended to upgrade the affected component.

Weakness: CWE-476 (NULL Pointer Dereference), CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2025-6375?

It affects 1 product.


Products: Pocoproject Poco.

## How do I fix CVE-2025-6375?

Upgrade to a fixed version.

## Is CVE-2025-6375 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6375 exists.

## Other vulnerabilities in poco

- [CVE-2023-52389](https://insights.sbomify.com/CVE-2023-52389/): Integer overflow in n/a (critical 9.8)
- [CVE-2025-45766](https://insights.sbomify.com/CVE-2025-45766/): Weak cryptography in n/a (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6375 and fix it if it is affected.

What it is: CVE-2025-6375 is a medium-severity vulnerability in poco, published on 21 Jun 2025. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6375 exists.

Affected product: poco. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6375/ (Markdown: https://insights.sbomify.com/CVE-2025-6375/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6375
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6375
- OSV: https://osv.dev/vulnerability/CVE-2025-6375

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6375/
Summaries are generated and may contain mistakes; the official description above is the record.
