# CVE-2025-6384: Improper Control of Dynamically-Managed Code Resources in Crafter Studio

> Authenticated developers can bypass Groovy Sandbox restrictions to execute arbitrary OS commands, leading to remote code execution.

- **Severity:** High 7.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2025
- **Updated:** 23 Jun 2025
- **Also known as:** GHSA-5644-3vgq-2ph5

## What is CVE-2025-6384?

CVE-2025-6384 is a high-severity code injection vulnerability in CrafterCMS, published on 19 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improper Control of Dynamically-Managed Code Resources vulnerability in Crafter Studio of CrafterCMS allows authenticated developers to execute OS commands via Groovy Sandbox Bypass.

By inserting malicious Groovy elements, an attacker may bypass Sandbox restrictions and obtain RCE (Remote Code Execution).

This issue affects CrafterCMS: from 4.0.0 through 4.2.2.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2025-6384?

2 open source packages ship an affected version, including org.craftercms:crafter-studio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.craftercms:crafter-studio` | Maven | From 4.0.0 | 4.3.0 |
| `org.craftercms:crafter-studio` | Maven | From 4.0.0 | 4.3.0 |

Products: Craftercms Craftercms.

## How do I fix CVE-2025-6384?

Upgrade org.craftercms:crafter-studio to 4.3.0 or later.

## Is CVE-2025-6384 being exploited?

There is no known exploitation of CVE-2025-6384 in the wild and no public exploit code.

Public exploit code:

- CVE-2025-6384: Groovy Sandbox Bypass 2 in CrafterCMS (github_poc): https://github.com/mbadanoiu/CVE-2025-6384
- PoC exploit for an authenticated RCE in CrafterCMS via Groovy sandbox bypass (CVE-2025-6384) (github_poc): https://github.com/maestro-ant/CrafterCMS-CVE-2025-6384

## Other vulnerabilities in CrafterCMS

- [CVE-2023-4136](https://insights.sbomify.com/CVE-2023-4136/): Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in Crafter Engine (high 7.4)
- [CVE-2025-0502](https://insights.sbomify.com/CVE-2025-0502/): Transmission of Private Resources into a New Sphere in Crafter Engine (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6384 and fix it if it is affected.

What it is: CVE-2025-6384 is a high-severity code injection vulnerability in CrafterCMS, published on 19 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-6384 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.craftercms:crafter-studio (Maven): affected from 4.0.0; fixed in 4.3.0
- org.craftercms:crafter-studio (Maven): affected from 4.0.0; fixed in 4.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6384/ (Markdown: https://insights.sbomify.com/CVE-2025-6384/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6384
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6384
- OSV: https://osv.dev/vulnerability/CVE-2025-6384

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6384/
Summaries are generated and may contain mistakes; the official description above is the record.
