# CVE-2025-6386: Timing Attack Vulnerability in parisneo/lollms

> Attackers can enumerate valid usernames and guess passwords by analyzing response time differences in the authentication function.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Jul 2025
- **Updated:** 7 Jul 2025
- **Also known as:** GHSA-j5pr-vrjj-9v4h, PYSEC-2026-1590

## What is CVE-2025-6386?

CVE-2025-6386 is a high-severity vulnerability in parisneo/lollms, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The parisneo/lollms repository is affected by a timing attack vulnerability in the `authenticate_user` function within the `lollms_authentication.py` file. This vulnerability allows attackers to enumerate valid usernames and guess passwords incrementally by analyzing response time differences. The affected version is the latest, and the issue is resolved in version 20.1. The vulnerability arises from the use of Python's default string equality operator for password comparison, which compares characters sequentially and exits on the first mismatch, leading to variable response times based on the number of matching initial characters.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2025-6386?

3 open source packages ship an affected version, including lollms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lollms` | PyPI | All versions to 11.0.0 | None |
| `lollms` | PyPI | All versions to 11.0.0 | None |
| `lollms` | PyPI | All versions to 11.0.0 | None |

## How do I fix CVE-2025-6386?

No fix has been published for CVE-2025-6386 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-6386 being exploited?

There is no known exploitation of CVE-2025-6386 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6386 and fix it if it is affected.

What it is: CVE-2025-6386 is a high-severity vulnerability in parisneo/lollms, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-6386 in the wild and no public exploit code.

Affected packages and fixed versions:
- lollms (PyPI): affected all versions up to 11.0.0; no fix listed
- lollms (PyPI): affected all versions up to 11.0.0; no fix listed
- lollms (PyPI): affected all versions up to 11.0.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6386/ (Markdown: https://insights.sbomify.com/CVE-2025-6386/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6386
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6386
- OSV: https://osv.dev/vulnerability/CVE-2025-6386

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6386/
Summaries are generated and may contain mistakes; the official description above is the record.
