# CVE-2025-64049: REDAXO CMS is vulnerable to XSS through its module management component

> Remote attackers can inject malicious scripts via module output code, leading to script execution when users view or edit articles in REDAXO CMS.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Nov 2025
- **Updated:** 25 Nov 2025
- **Also known as:** GHSA-vqc7-7fj4-3fm3

## What is CVE-2025-64049?

CVE-2025-64049 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A stored cross-site scripting (XSS) vulnerability in the module management component in REDAXO CMS 5.20.0 allows remote users to inject arbitrary web script or HTML via the Output code field in modules. The payload is executed when a user views or edits an article by adding slice that uses the compromised module.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-64049?

2 open source packages ship an affected version, including redaxo/source. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redaxo/source` | Packagist | All versions | 5.20.1 |
| `redaxo/source` | Packagist | All versions | 5.20.1 |

Products: Redaxo Redaxo.

## How do I fix CVE-2025-64049?

Upgrade redaxo/source to 5.20.1 or later.

## Is CVE-2025-64049 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64049 exists.

## Other vulnerabilities in n/a

- [CVE-2018-18200](https://insights.sbomify.com/CVE-2018-18200/): SQL injection in n/a (critical 9.8)
- [CVE-2018-17831](https://insights.sbomify.com/CVE-2018-17831/): SQL injection in n/a (critical 9.8)
- [CVE-2026-21857](https://insights.sbomify.com/CVE-2026-21857/): Redaxo has Path Traversal in Backup Addon Leading to Arbitrary File Read (high 8.3)
- [CVE-2006-2843](https://insights.sbomify.com/CVE-2006-2843/): Code injection in n/a (high 7.5)
- [CVE-2006-2844](https://insights.sbomify.com/CVE-2006-2844/): Multiple PHP remote file inclusion vulnerabilities in Redaxo 3.0 allow remote attackers to execute arbitrary PHP code via a URL in the REX[I (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64049 and fix it if it is affected.

What it is: CVE-2025-64049 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64049 exists.

Affected packages and fixed versions:
- redaxo/source (Packagist): affected all versions; fixed in 5.20.1
- redaxo/source (Packagist): affected all versions; fixed in 5.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64049/ (Markdown: https://insights.sbomify.com/CVE-2025-64049/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64049
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64049
- OSV: https://osv.dev/vulnerability/CVE-2025-64049

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64049/
Summaries are generated and may contain mistakes; the official description above is the record.
