# CVE-2025-64076: cbor2 C extension decoder flaws can cause denial of service

> Remote attackers can cause denial of service via crashes or memory exhaustion by sending crafted CBOR data to applications using the cbor2 library.

- **Severity:** High 7.5 (`CVSS:3.1/AC:L/AV:N/A:H/C:N/I:N/PR:N/S:U/UI:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2025
- **Updated:** 19 Nov 2025
- **Also known as:** AZL-70516, DEBIAN-CVE-2025-64076, GHSA-9q9c-vjxh-p795, PYSEC-2025-238, UBUNTU-CVE-2025-64076

## What is CVE-2025-64076?

CVE-2025-64076 is a high-severity vulnerability in n/a, published on 18 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple vulnerabilities exist in cbor2 through version 5.7.0 in the decode_definite_long_string() function of the C extension decoder (source/decoder.c): (1) Integer Underflow Leading to Out-of-Bounds Read (CWE-191, CWE-125): An incorrect variable reference and missing state reset in the chunk processing loop causes buffer_length to not be reset to zero after UTF-8 character consumption. This results in subsequent chunk_length calculations producing negative values (e.g., chunk_length = 65536 - buffer_length), which are passed as signed integers to the read() method, potentially triggering unlimited read operations and resource exhaustion. (2) Memory Leak via Missing Reference Count Release (CWE-401): The main processing loop fails to release Python object references (Py_DECREF) for chunk objects allocated in each iteration. For CBOR strings longer than 65536 bytes, this causes cumulative memory leaks proportional to the payload size, enabling memory exhaustion attacks through repeated processing of large CBOR payloads. Both vulnerabilities can be exploited remotely without authentication by sending specially-crafted CBOR data containing definite-length text strings with multi-byte UTF-8 characters positioned at 65536-byte chunk boundaries. Successful exploitation results in denial of service through process crashes (CBORDecodeEOF exceptions) or memory exhaustion. The vulnerabilities affect all applications using cbor2's C extension to process untrusted CBOR data, including web APIs, IoT data collectors, and message queue processors. Fixed in commit 851473490281f82d82560b2368284ef33cf6e8f9 pushed with released version 5.7.1.

Weakness: CWE-191 (Integer Underflow (Wrap or Wraparound))

## Which versions are affected by CVE-2025-64076?

3 open source packages ship an affected version, including cbor2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cbor2` | PyPI | All versions | 5.7.1 |
| `cbor2` | PyPI | All versions | 5.7.1 |
| `cbor2` | PyPI | All versions | 5.7.1 |

Products: Agronholm Cbor2.

## How do I fix CVE-2025-64076?

Upgrade cbor2 to 5.7.1 or later.

## Is CVE-2025-64076 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64076 exists.

## Other vulnerabilities in n/a

- [CVE-2026-26209](https://insights.sbomify.com/CVE-2026-26209/): cbor2 has a Denial of Service via Uncontrolled Recursion in cbor2.loads (high 7.5)
- [CVE-2024-26134](https://insights.sbomify.com/CVE-2024-26134/): CBOR2 decoder has potential buffer overflow (high 7.5)
- [CVE-2025-68131](https://insights.sbomify.com/CVE-2025-68131/): CBORDecoder reuse can leak shareable values across decode calls (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64076 and fix it if it is affected.

What it is: CVE-2025-64076 is a high-severity vulnerability in n/a, published on 18 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64076 exists.

Affected packages and fixed versions:
- cbor2 (PyPI): affected all versions; fixed in 5.7.1
- cbor2 (PyPI): affected all versions; fixed in 5.7.1
- cbor2 (PyPI): affected all versions; fixed in 5.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64076/ (Markdown: https://insights.sbomify.com/CVE-2025-64076/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64076
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64076
- OSV: https://osv.dev/vulnerability/CVE-2025-64076

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64076/
Summaries are generated and may contain mistakes; the official description above is the record.
