{"answers":{"affected":"2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-oauth2.","exploited":"There is no known exploitation of CVE-2025-64099 in the wild and no public exploit code.","fix":"Upgrade org.openidentityplatform.openam:openam-oauth2 to 16.0.3 or later.","what":"CVE-2025-64099 is a high-severity authentication bypass vulnerability in OpenIdentityPlatform OpenAM, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64099 and fix it if it is affected.\n\nWhat it is: CVE-2025-64099 is a high-severity authentication bypass vulnerability in OpenIdentityPlatform OpenAM, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-64099 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openidentityplatform.openam:openam-oauth2 (Maven): affected all versions; fixed in 16.0.3\n- org.openidentityplatform.openam:openam-oauth2 (Maven): affected all versions; fixed in 16.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64099/ (Markdown: https://insights.sbomify.com/CVE-2025-64099/index.md)","id":"CVE-2025-64099","markdown":"https://insights.sbomify.com/CVE-2025-64099/index.md","name":"CVE-2025-64099","record":{"aliases":["GHSA-39hr-239p-fhqc"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"OpenAM access management","requires_auth":"none","summary":"Attackers can inject arbitrary claims into OIDC tokens when claims support is enabled, allowing them to impersonate users and bypass authentication.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Open Access Management (OpenAM) is an access management solution. In versions prior to 16.0.0, if the \"claims_parameter_supported\" parameter is activated, it is possible, thanks to the \"oidc-claims-extension.groovy\" script, to inject the value of one's choice into a claim contained in the id_token or in the user_info. In the request of an authorize function, a claims parameter containing a JSON file can be injected. This JSON file allows attackers to customize the claims returned by the \"id_token\" and \"user_info\" files. This allows for a very wide range of vulnerabilities depending on how clients use claims. For example, if some clients rely on an email field to identify a user, an attacker can choose the email address they want, and therefore assume any identity they choose. Version 16.0.0 fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenAM allows use of arbitrary OIDC requested claims values in id_token and user_info","id":"CVE-2025-64099","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"CKAN Vulnerable to Session Cookie Fixation","id":"CVE-2025-64100"},"packages":[{"ecosystem":"Maven","fixed":["16.0.3"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-oauth2","purl":null,"source":"GHSA-39hr-239p-fhqc"},{"ecosystem":"Maven","fixed":["16.0.3"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-oauth2","purl":"pkg:maven/org.openidentityplatform.openam/openam-oauth2","source":"GHSA-39hr-239p-fhqc"}],"prev":{"headline":"FastDDS has Out-of-memory in readOctetVector via Manipulated DATA Submessage when DDS Security is enabled","id":"CVE-2025-64098"},"products":["OpenAM"],"published":"2025-11-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-12","vendors":["OpenIdentityPlatform"]},"summary":"Attackers can inject arbitrary claims into OIDC tokens when claims support is enabled, allowing them to impersonate users and bypass authentication.","url":"https://insights.sbomify.com/CVE-2025-64099/"}