# CVE-2025-64099: OpenAM allows use of arbitrary OIDC requested claims values in id_token and user_info

> Attackers can inject arbitrary claims into OIDC tokens when claims support is enabled, allowing them to impersonate users and bypass authentication.

- **Severity:** High 8.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Nov 2025
- **Updated:** 12 Nov 2025
- **Also known as:** GHSA-39hr-239p-fhqc

## What is CVE-2025-64099?

CVE-2025-64099 is a high-severity authentication bypass vulnerability in OpenIdentityPlatform OpenAM, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Open Access Management (OpenAM) is an access management solution. In versions prior to 16.0.0, if the "claims_parameter_supported" parameter is activated, it is possible, thanks to the "oidc-claims-extension.groovy" script, to inject the value of one's choice into a claim contained in the id_token or in the user_info. In the request of an authorize function, a claims parameter containing a JSON file can be injected. This JSON file allows attackers to customize the claims returned by the "id_token" and "user_info" files. This allows for a very wide range of vulnerabilities depending on how clients use claims. For example, if some clients rely on an email field to identify a user, an attacker can choose the email address they want, and therefore assume any identity they choose. Version 16.0.0 fixes the issue.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2025-64099?

2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-oauth2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openidentityplatform.openam:openam-oauth2` | Maven | All versions | 16.0.3 |
| `org.openidentityplatform.openam:openam-oauth2` | Maven | All versions | 16.0.3 |

## How do I fix CVE-2025-64099?

Upgrade org.openidentityplatform.openam:openam-oauth2 to 16.0.3 or later.

## Is CVE-2025-64099 being exploited?

There is no known exploitation of CVE-2025-64099 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64099 and fix it if it is affected.

What it is: CVE-2025-64099 is a high-severity authentication bypass vulnerability in OpenIdentityPlatform OpenAM, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64099 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.openidentityplatform.openam:openam-oauth2 (Maven): affected all versions; fixed in 16.0.3
- org.openidentityplatform.openam:openam-oauth2 (Maven): affected all versions; fixed in 16.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64099/ (Markdown: https://insights.sbomify.com/CVE-2025-64099/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64099
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64099
- OSV: https://osv.dev/vulnerability/CVE-2025-64099

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64099/
Summaries are generated and may contain mistakes; the official description above is the record.
