CVE-2025-64100 CKAN Vulnerable to Session Cookie Fixation
Attackers can hijack user sessions in CKAN if server-side session storage is enabled, allowing unauthorized access to victim accounts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-64100?
CVE-2025-64100 is a medium-severity authentication bypass vulnerability in ckan, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, session ids could be fixed by an attacker if the site is configured with server-side session storage (CKAN uses cookie-based session storage by default). The attacker would need to either set a cookie on the victim's browser or steal the victim's currently valid session. Session identifiers are now regenerated after each login. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4
Weakness: CWE-384
Which versions are affected by CVE-2025-64100?
5 open source packages ship an affected version, including ckan.
| Package | Affected | Fixed in |
|---|---|---|
ckan PyPI | From 2.10.0 | 2.10.9, 2.11.4 |
ckan PyPI | From 2.10.0 | 2.10.9 |
ckan PyPI | From 2.10.0 | 2.10.9 |
ckan PyPI | From 2.11.0 | 2.11.4 |
ckan PyPI | From 2.11.0 | 2.11.4 |
How do I fix CVE-2025-64100?
Upgrade ckan to a fixed version for your release line: 2.10.9 or 2.11.4.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-64100 being exploited?
There is no known exploitation of CVE-2025-64100 in the wild and no public exploit code.
Sources
Also known as GHSA-2hvh-cw5c-8q8q, PYSEC-2026-1246.