{"answers":{"affected":"5 open source packages ship an affected version, including ckan.","exploited":"There is no known exploitation of CVE-2025-64100 in the wild and no public exploit code.","fix":"Upgrade ckan to a fixed version for your release line: 2.10.9 or 2.11.4.","what":"CVE-2025-64100 is a medium-severity authentication bypass vulnerability in ckan, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-64100 and fix it if it is affected.\n\nWhat it is: CVE-2025-64100 is a medium-severity authentication bypass vulnerability in ckan, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-64100 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ckan (PyPI): affected from 2.10.0; fixed in 2.10.9, 2.11.4\n- ckan (PyPI): affected from 2.10.0; fixed in 2.10.9\n- ckan (PyPI): affected from 2.10.0; fixed in 2.10.9\n- ckan (PyPI): affected from 2.11.0; fixed in 2.11.4\n- ckan (PyPI): affected from 2.11.0; fixed in 2.11.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64100/ (Markdown: https://insights.sbomify.com/CVE-2025-64100/index.md)","id":"CVE-2025-64100","markdown":"https://insights.sbomify.com/CVE-2025-64100/index.md","name":"CVE-2025-64100","record":{"aliases":["GHSA-2hvh-cw5c-8q8q","PYSEC-2026-1246"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"CKAN data portal","requires_auth":"none","summary":"Attackers can hijack user sessions in CKAN if server-side session storage is enabled, allowing unauthorized access to victim accounts.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-384","name":"Session Fixation"}],"description":"CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, session ids could be fixed by an attacker if the site is configured with server-side session storage (CKAN uses cookie-based session storage by default). The attacker would need to either set a cookie on the victim's browser or steal the victim's currently valid session. Session identifiers are now regenerated after each login. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CKAN Vulnerable to Session Cookie Fixation","id":"CVE-2025-64100","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":5,"n_references":2,"next":{"headline":"ZITADEL Vulnerable to Account Takeover via Malicious Forwarded Header Injection","id":"CVE-2025-64101"},"packages":[{"ecosystem":"PyPI","fixed":["2.10.9","2.11.4"],"introduced":["2.10.0","2.11.0"],"last_affected":[],"package":"ckan","purl":"pkg:pypi/ckan","source":"PYSEC-2026-1246"},{"ecosystem":"PyPI","fixed":["2.10.9"],"introduced":["2.10.0"],"last_affected":[],"package":"ckan","purl":null,"source":"GHSA-2hvh-cw5c-8q8q"},{"ecosystem":"PyPI","fixed":["2.10.9"],"introduced":["2.10.0"],"last_affected":[],"package":"ckan","purl":"pkg:pypi/ckan","source":"GHSA-2hvh-cw5c-8q8q"},{"ecosystem":"PyPI","fixed":["2.11.4"],"introduced":["2.11.0"],"last_affected":[],"package":"ckan","purl":null,"source":"GHSA-2hvh-cw5c-8q8q"},{"ecosystem":"PyPI","fixed":["2.11.4"],"introduced":["2.11.0"],"last_affected":[],"package":"ckan","purl":"pkg:pypi/ckan","source":"GHSA-2hvh-cw5c-8q8q"}],"prev":{"headline":"OpenAM allows use of arbitrary OIDC requested claims values in id_token and user_info","id":"CVE-2025-64099"},"products":["ckan"],"published":"2025-10-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-29","vendors":["ckan"]},"summary":"Attackers can hijack user sessions in CKAN if server-side session storage is enabled, allowing unauthorized access to victim accounts.","url":"https://insights.sbomify.com/CVE-2025-64100/"}