# CVE-2025-64100: CKAN Vulnerable to Session Cookie Fixation

> Attackers can hijack user sessions in CKAN if server-side session storage is enabled, allowing unauthorized access to victim accounts.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Oct 2025
- **Updated:** 29 Oct 2025
- **Also known as:** GHSA-2hvh-cw5c-8q8q, PYSEC-2026-1246

## What is CVE-2025-64100?

CVE-2025-64100 is a medium-severity authentication bypass vulnerability in ckan, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, session ids could be fixed by an attacker if the site is configured with server-side session storage (CKAN uses cookie-based session storage by default). The attacker would need to either set a cookie on the victim's browser or steal the victim's currently valid session. Session identifiers are now regenerated after each login. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2025-64100?

5 open source packages ship an affected version, including ckan.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckan` | PyPI | From 2.10.0 | 2.10.9, 2.11.4 |
| `ckan` | PyPI | From 2.10.0 | 2.10.9 |
| `ckan` | PyPI | From 2.10.0 | 2.10.9 |
| `ckan` | PyPI | From 2.11.0 | 2.11.4 |
| `ckan` | PyPI | From 2.11.0 | 2.11.4 |

## How do I fix CVE-2025-64100?

Upgrade ckan to a fixed version for your release line: 2.10.9 or 2.11.4.

## Is CVE-2025-64100 being exploited?

There is no known exploitation of CVE-2025-64100 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64100 and fix it if it is affected.

What it is: CVE-2025-64100 is a medium-severity authentication bypass vulnerability in ckan, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-64100 in the wild and no public exploit code.

Affected packages and fixed versions:
- ckan (PyPI): affected from 2.10.0; fixed in 2.10.9, 2.11.4
- ckan (PyPI): affected from 2.10.0; fixed in 2.10.9
- ckan (PyPI): affected from 2.10.0; fixed in 2.10.9
- ckan (PyPI): affected from 2.11.0; fixed in 2.11.4
- ckan (PyPI): affected from 2.11.0; fixed in 2.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64100/ (Markdown: https://insights.sbomify.com/CVE-2025-64100/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64100
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64100
- OSV: https://osv.dev/vulnerability/CVE-2025-64100

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64100/
Summaries are generated and may contain mistakes; the official description above is the record.
