CVE-2025-64102 Zitadel allows brute-forcing authentication factors

High 7.7 Published Updated

Attackers can brute-force authentication factors like OTPs and passwords because lockout mechanisms are disabled by default and incomplete in newer APIs.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-64102?

CVE-2025-64102 is a high-severity authentication bypass vulnerability in zitadel, published on 29 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Zitadel is open-source identity infrastructure software. Prior to 4.6.0, 3.4.3, and 2.71.18, an attacker can perform an online brute-force attack on OTP, TOTP, and passwords. While Zitadel allows preventing online brute force attacks in scenarios like TOTP, Email OTP, or passwords using a lockout mechanism. The mechanism is not enabled by default and can cause a denial of service for the corresponding user if enabled. Additionally, the mitigation strategies were not fully implemented in the more recent resource-based APIs. This vulnerability is fixed in 4.6.0, 3.4.3, and 2.71.18.

Weakness: CWE-307

Which versions are affected by CVE-2025-64102?

5 open source packages ship an affected version, including github.com/zitadel/zitadel and github.com/zitadel/zitadel/v2. It affects 1 product.

PackageAffectedFixed in
github.com/zitadel/zitadel GoAll versionsNone
github.com/zitadel/zitadel GoAll versions1.80.0-v2.20.0.20251029090735-b8db8cdf9cc8
github.com/zitadel/zitadel GoAll versions1.80.0-v2.20.0.20251029090735-b8db8cdf9cc8
github.com/zitadel/zitadel/v2 GoAll versions2.71.18
github.com/zitadel/zitadel/v2 GoAll versions2.71.18

Products include Zitadel Zitadel.

How do I fix CVE-2025-64102?

Upgrade github.com/zitadel/zitadel to 1.80.0-v2.20.0.20251029090735-b8db8cdf9cc8 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-64102 being exploited?

There is no known exploitation of CVE-2025-64102 in the wild and no public exploit code.

Sources

Also known as GHSA-xrw9-r35x-x878, GO-2025-4085.

Is CVE-2025-64102 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free