# CVE-2025-64102: Zitadel allows brute-forcing authentication factors

> Attackers can brute-force authentication factors like OTPs and passwords because lockout mechanisms are disabled by default and incomplete in newer APIs.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2025
- **Updated:** 30 Oct 2025
- **Also known as:** GHSA-xrw9-r35x-x878, GO-2025-4085

## What is CVE-2025-64102?

CVE-2025-64102 is a high-severity authentication bypass vulnerability in zitadel, published on 29 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Zitadel is open-source identity infrastructure software. Prior to 4.6.0, 3.4.3, and 2.71.18, an attacker can perform an online brute-force attack on OTP, TOTP, and passwords. While Zitadel allows preventing online brute force attacks in scenarios like TOTP, Email OTP, or passwords using a lockout mechanism. The mechanism is not enabled by default and can cause a denial of service for the corresponding user if enabled. Additionally, the mitigation strategies were not fully implemented in the more recent resource-based APIs. This vulnerability is fixed in 4.6.0, 3.4.3, and 2.71.18.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2025-64102?

5 open source packages ship an affected version, including github.com/zitadel/zitadel and github.com/zitadel/zitadel/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/zitadel/zitadel` | Go | All versions | None |
| `github.com/zitadel/zitadel` | Go | All versions | 1.80.0-v2.20.0.20251029090735-b8db8cdf9cc8 |
| `github.com/zitadel/zitadel` | Go | All versions | 1.80.0-v2.20.0.20251029090735-b8db8cdf9cc8 |
| `github.com/zitadel/zitadel/v2` | Go | All versions | 2.71.18 |
| `github.com/zitadel/zitadel/v2` | Go | All versions | 2.71.18 |

Products: Zitadel Zitadel.

## How do I fix CVE-2025-64102?

Upgrade github.com/zitadel/zitadel to 1.80.0-v2.20.0.20251029090735-b8db8cdf9cc8 or later.

## Is CVE-2025-64102 being exploited?

There is no known exploitation of CVE-2025-64102 in the wild and no public exploit code.

## Other vulnerabilities in zitadel

- [CVE-2026-29191](https://insights.sbomify.com/CVE-2026-29191/): ZITADEL: 1-Click Account Takeover via XSS in /saml-post Endpoint (critical 9.3)
- [CVE-2025-67494](https://insights.sbomify.com/CVE-2025-67494/): ZITADEL Vulnerable to Unauthenticated Full-Read SSRF via V2 Login (critical 9.3)
- [CVE-2025-27507](https://insights.sbomify.com/CVE-2025-27507/): IDOR Vulnerabilities in ZITADEL's Admin API that Primarily Impact LDAP Configurations (critical 9.0)
- [CVE-2025-64103](https://insights.sbomify.com/CVE-2025-64103/): Zitadel Bypass Second Authentication Factor (high 8.7)
- [CVE-2025-31123](https://insights.sbomify.com/CVE-2025-31123/): Zitadel Expired JWT Keys Usable for Authorization Grants (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64102 and fix it if it is affected.

What it is: CVE-2025-64102 is a high-severity authentication bypass vulnerability in zitadel, published on 29 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64102 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/zitadel/zitadel (Go): affected all versions; no fix listed
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 1.80.0-v2.20.0.20251029090735-b8db8cdf9cc8
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 1.80.0-v2.20.0.20251029090735-b8db8cdf9cc8
- github.com/zitadel/zitadel/v2 (Go): affected all versions; fixed in 2.71.18
- github.com/zitadel/zitadel/v2 (Go): affected all versions; fixed in 2.71.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64102/ (Markdown: https://insights.sbomify.com/CVE-2025-64102/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64102
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64102
- OSV: https://osv.dev/vulnerability/CVE-2025-64102

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64102/
Summaries are generated and may contain mistakes; the official description above is the record.
