# CVE-2025-64103: Zitadel Bypass Second Authentication Factor

> Attackers can bypass second-factor authentication in Zitadel if MFA is configured but not strictly enforced by policy, potentially compromising accounts.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2025
- **Updated:** 30 Oct 2025
- **Also known as:** GHSA-cfjq-28r2-4jv5, GO-2025-4083

## What is CVE-2025-64103?

CVE-2025-64103 is a high-severity authentication bypass vulnerability in zitadel, published on 29 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Starting from 2.53.6, 2.54.3, and 2.55.0, Zitadel only required multi factor authentication in case the login policy has either enabled requireMFA or requireMFAForLocalUsers. If a user has set up MFA without this requirement, Zitadel would consider single factor auhtenticated sessions as valid as well and not require multiple factors. Bypassing second authentication factors weakens multifactor authentication and enables attackers to bypass the more secure factor. An attacker can target the TOTP code alone, only six digits, bypassing password verification entirely and potentially compromising accounts with 2FA enabled. This vulnerability is fixed in 4.6.0, 3.4.3, and 2.71.18.

Weakness: CWE-308 (Use of Single-factor Authentication), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-64103?

9 open source packages ship an affected version, including github.com/zitadel/zitadel/v2 and github.com/zitadel/zitadel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/zitadel/zitadel/v2` | Go | From 2.53.6 to 2.53.9 | None |
| `github.com/zitadel/zitadel/v2` | Go | From 2.53.6 to 2.53.9 | None |
| `github.com/zitadel/zitadel/v2` | Go | From 2.54.3 to 2.54.10 | None |
| `github.com/zitadel/zitadel/v2` | Go | From 2.54.3 to 2.54.10 | None |
| `github.com/zitadel/zitadel/v2` | Go | From 2.55.0 | 2.71.18 |
| `github.com/zitadel/zitadel/v2` | Go | From 2.55.0 | 2.71.18 |
| `github.com/zitadel/zitadel` | Go | All versions | None |
| `github.com/zitadel/zitadel` | Go | All versions | 1.80.0-v2.20.0.20251029091250-b284f8474eed |
| `github.com/zitadel/zitadel` | Go | All versions | 1.80.0-v2.20.0.20251029091250-b284f8474eed |

Products: Zitadel Zitadel.

## How do I fix CVE-2025-64103?

Upgrade github.com/zitadel/zitadel/v2 to 2.71.18 or later.

## Is CVE-2025-64103 being exploited?

There is no known exploitation of CVE-2025-64103 in the wild and no public exploit code.

## Other vulnerabilities in zitadel

- [CVE-2026-29191](https://insights.sbomify.com/CVE-2026-29191/): ZITADEL: 1-Click Account Takeover via XSS in /saml-post Endpoint (critical 9.3)
- [CVE-2025-67494](https://insights.sbomify.com/CVE-2025-67494/): ZITADEL Vulnerable to Unauthenticated Full-Read SSRF via V2 Login (critical 9.3)
- [CVE-2025-27507](https://insights.sbomify.com/CVE-2025-27507/): IDOR Vulnerabilities in ZITADEL's Admin API that Primarily Impact LDAP Configurations (critical 9.0)
- [CVE-2025-31123](https://insights.sbomify.com/CVE-2025-31123/): Zitadel Expired JWT Keys Usable for Authorization Grants (high 8.7)
- [CVE-2024-29891](https://insights.sbomify.com/CVE-2024-29891/): ZITADEL Improper Content-Type Validation Leads to Account Takeover via Stored XSS + CSP Bypass (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64103 and fix it if it is affected.

What it is: CVE-2025-64103 is a high-severity authentication bypass vulnerability in zitadel, published on 29 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64103 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/zitadel/zitadel/v2 (Go): affected from 2.53.6 up to 2.53.9; no fix listed
- github.com/zitadel/zitadel/v2 (Go): affected from 2.53.6 up to 2.53.9; no fix listed
- github.com/zitadel/zitadel/v2 (Go): affected from 2.54.3 up to 2.54.10; no fix listed
- github.com/zitadel/zitadel/v2 (Go): affected from 2.54.3 up to 2.54.10; no fix listed
- github.com/zitadel/zitadel/v2 (Go): affected from 2.55.0; fixed in 2.71.18
- github.com/zitadel/zitadel/v2 (Go): affected from 2.55.0; fixed in 2.71.18
- github.com/zitadel/zitadel (Go): affected all versions; no fix listed
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 1.80.0-v2.20.0.20251029091250-b284f8474eed
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 1.80.0-v2.20.0.20251029091250-b284f8474eed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64103/ (Markdown: https://insights.sbomify.com/CVE-2025-64103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64103
- OSV: https://osv.dev/vulnerability/CVE-2025-64103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64103/
Summaries are generated and may contain mistakes; the official description above is the record.
