CVE-2025-64107 Cursor is Vulnerable to Path Manipulation Using Backslashes on Windows

High 8.8 Published Updated

Attackers can bypass path validation using backslashes on Windows to overwrite sensitive files and achieve remote code execution in Cursor.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-64107?

CVE-2025-64107 is a high-severity path traversal vulnerability in cursor, published on 4 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Cursor is a code editor built for programming with AI. In versions 1.7.52 and below, manipulating internal settings may lead to RCE. Cursor detects path manipulation via forward slashes (./.cursor/./././././mcp.json etc.), and requires human approval to complete the operation. However, the same kind of manipulation using backslashes was not correctly detected, allowing an attacker who had already achieved prompt injection or some other level of control to overwrite sensitive editor files without approval on Windows machines. This issue is fixed in version 2.0.

Weakness: CWE-22

Which versions are affected by CVE-2025-64107?

It affects 1 product.

Products include Anysphere Cursor.

How do I fix CVE-2025-64107?

No fix has been published for CVE-2025-64107 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2025-64107 being exploited?

There is no known exploitation of CVE-2025-64107 in the wild and no public exploit code.

Sources

Is CVE-2025-64107 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free