# CVE-2025-64107: Cursor is Vulnerable to Path Manipulation Using Backslashes on Windows

> Attackers can bypass path validation using backslashes on Windows to overwrite sensitive files and achieve remote code execution in Cursor.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Nov 2025
- **Updated:** 7 Nov 2025

## What is CVE-2025-64107?

CVE-2025-64107 is a high-severity path traversal vulnerability in cursor, published on 4 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cursor is a code editor built for programming with AI. In versions 1.7.52 and below, manipulating internal settings may lead to RCE. Cursor detects path manipulation via forward slashes (./.cursor/./././././mcp.json etc.), and requires human approval to complete the operation. However, the same kind of manipulation using backslashes was not correctly detected, allowing an attacker who had already achieved prompt injection or some other level of control to overwrite sensitive editor files without approval on Windows machines. This issue is fixed in version 2.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-64107?

It affects 1 product.


Products: Anysphere Cursor.

## How do I fix CVE-2025-64107?

No fix has been published for CVE-2025-64107 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-64107 being exploited?

There is no known exploitation of CVE-2025-64107 in the wild and no public exploit code.

## Other vulnerabilities in cursor

- [CVE-2026-50548](https://insights.sbomify.com/CVE-2026-50548/): Cursor Desktop sandbox escape via agent-controlled working directory (critical 9.3)
- [CVE-2026-50549](https://insights.sbomify.com/CVE-2026-50549/): Cursor Desktop sandbox escape via symlink and failed path canonicalization (critical 9.3)
- [CVE-2025-64106](https://insights.sbomify.com/CVE-2025-64106/): Cursor: Speedbump Modal Bypass in MCP Server Deep-Link (high 8.8)
- [CVE-2025-64108](https://insights.sbomify.com/CVE-2025-64108/): Cursor's Sensitive File Modification can Lead to NTFS Path Quirks (high 8.8)
- [CVE-2025-61591](https://insights.sbomify.com/CVE-2025-61591/): Cursor CLI's Cursor Agent MCP OAuth2 Communication is Vulnerable to Remote Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64107 and fix it if it is affected.

What it is: CVE-2025-64107 is a high-severity path traversal vulnerability in cursor, published on 4 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64107 in the wild and no public exploit code.

Affected product: cursor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64107/ (Markdown: https://insights.sbomify.com/CVE-2025-64107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64107
- OSV: https://osv.dev/vulnerability/CVE-2025-64107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64107/
Summaries are generated and may contain mistakes; the official description above is the record.
