CVE-2025-64110 Cursor: Authentication Bypass Possible via New Cursorignore Write

High 8.7 Published Updated

A logic bug in Cursor allows malicious agents to bypass cursorignore protections and read sensitive files by creating new configuration files.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-64110?

CVE-2025-64110 is a high-severity authentication bypass vulnerability in cursor, published on 4 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Cursor is a code editor built for programming with AI. In versions 1.7.23 and below, a logic bug allows a malicious agent to read sensitive files that should be protected via cursorignore. An attacker who has already achieved prompt injection, or a malicious model, could create a new cursorignore file which can invalidate the configuration of pre-existing ones. This could allow a malicious agent to read protected files. This issue is fixed in version 2.0.

Weakness: CWE-284

Which versions are affected by CVE-2025-64110?

It affects 1 product.

Products include Anysphere Cursor.

How do I fix CVE-2025-64110?

No fix has been published for CVE-2025-64110 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-64110 being exploited?

There is no known exploitation of CVE-2025-64110 in the wild and no public exploit code.

Sources

Is CVE-2025-64110 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free