CVE-2025-64111 Gogs's update .git/config file allows remote command execution
Attackers can achieve remote command execution by updating .git/config files in Gogs, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64111?
CVE-2025-64111 is a critical command injection vulnerability in gogs, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, due to the insufficient patch for CVE-2024-56731, it's still possible to update files in the .git directory and achieve remote command execution. This issue has been patched in versions 0.13.4 and 0.14.0+dev.
Weakness: CWE-78
Which versions are affected by CVE-2025-64111?
3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gogs.io/gogs Go | All versions | None |
gogs.io/gogs Go | All versions | 0.13.4 |
gogs.io/gogs Go | All versions | 0.13.4 |
Products include Gogs Gogs.
How do I fix CVE-2025-64111?
Upgrade gogs.io/gogs to 0.13.4 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2025-64111 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64111 exists.
Other vulnerabilities in gogs
Sources
Also known as GHSA-gg64-xxr9-qhjp, GO-2026-4448.