{"answers":{"affected":"3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64111 exists.","fix":"Upgrade gogs.io/gogs to 0.13.4 or later.","what":"CVE-2025-64111 is a critical command injection vulnerability in gogs, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64111 and fix it if it is affected.\n\nWhat it is: CVE-2025-64111 is a critical command injection vulnerability in gogs, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64111 exists.\n\nAffected packages and fixed versions:\n- gogs.io/gogs (Go): affected all versions; no fix listed\n- gogs.io/gogs (Go): affected all versions; fixed in 0.13.4\n- gogs.io/gogs (Go): affected all versions; fixed in 0.13.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64111/ (Markdown: https://insights.sbomify.com/CVE-2025-64111/index.md)","id":"CVE-2025-64111","markdown":"https://insights.sbomify.com/CVE-2025-64111/index.md","name":"CVE-2025-64111","record":{"aliases":["GHSA-gg64-xxr9-qhjp","GO-2026-4448"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Self-hosted Git service","requires_auth":"none","summary":"Attackers can achieve remote command execution by updating .git/config files in Gogs, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"gogs","vendor":"gogs"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, due to the insufficient patch for CVE-2024-56731, it's still possible to update files in the .git directory and achieve remote command execution. This issue has been patched in versions 0.13.4 and 0.14.0+dev.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Gogs's update .git/config file allows remote command execution","id":"CVE-2025-64111","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Statmatic vulnerable to Stored Cross-Site Scripting","id":"CVE-2025-64112"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":"pkg:golang/gogs.io/gogs","source":"GO-2026-4448"},{"ecosystem":"Go","fixed":["0.13.4"],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":null,"source":"GHSA-gg64-xxr9-qhjp"},{"ecosystem":"Go","fixed":["0.13.4"],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":"pkg:golang/gogs.io/gogs","source":"GHSA-gg64-xxr9-qhjp"}],"prev":{"headline":"Cursor: Authentication Bypass Possible via New Cursorignore Write","id":"CVE-2025-64110"},"products":["gogs"],"published":"2026-02-06","related":[{"cvss_score":8.7,"headline":"Gogs Path Traversal","id":"CVE-2025-8110","kev_date_added":"2026-01-12","published":"2025-12-10"},{"cvss_score":10,"headline":"Gogs deletion of internal files allows remote command execution","id":"CVE-2024-56731","kev_date_added":null,"published":"2025-06-24"},{"cvss_score":10,"headline":"Remote Command Execution in gogs/gogs","id":"CVE-2022-1884","kev_date_added":null,"published":"2024-11-15"},{"cvss_score":10,"headline":"OS Command Injection in gogs/gogs","id":"CVE-2022-1986","kev_date_added":null,"published":"2022-06-09"},{"cvss_score":10,"headline":"Path Traversal in gogs/gogs","id":"CVE-2022-1992","kev_date_added":null,"published":"2022-06-08"},{"cvss_score":9.9,"headline":"Duplicate Advisory: github.com/gogs/gogs affected by CVE-2024-39930","id":"CVE-2024-39930","kev_date_added":null,"published":"2024-07-04"},{"cvss_score":9.9,"headline":"Duplicate Advisory: Gogs allows deletion of internal files","id":"CVE-2024-39931","kev_date_added":null,"published":"2024-07-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["gogs"]},"summary":"Attackers can achieve remote command execution by updating .git/config files in Gogs, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2025-64111/"}