# CVE-2025-64111: Gogs's update .git/config file allows remote command execution

> Attackers can achieve remote command execution by updating .git/config files in Gogs, requiring an upgrade to patched versions.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-gg64-xxr9-qhjp, GO-2026-4448

## What is CVE-2025-64111?

CVE-2025-64111 is a critical command injection vulnerability in gogs, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, due to the insufficient patch for CVE-2024-56731, it's still possible to update files in the .git directory and achieve remote command execution. This issue has been patched in versions 0.13.4 and 0.14.0+dev.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-64111?

3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | None |
| `gogs.io/gogs` | Go | All versions | 0.13.4 |
| `gogs.io/gogs` | Go | All versions | 0.13.4 |

Products: Gogs Gogs.

## How do I fix CVE-2025-64111?

Upgrade gogs.io/gogs to 0.13.4 or later.

## Is CVE-2025-64111 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64111 exists.

## Other vulnerabilities in gogs

- [CVE-2025-8110](https://insights.sbomify.com/CVE-2025-8110/): Gogs Path Traversal (high 8.7, exploited in the wild)
- [CVE-2024-56731](https://insights.sbomify.com/CVE-2024-56731/): Gogs deletion of internal files allows remote command execution (critical 10.0)
- [CVE-2022-1884](https://insights.sbomify.com/CVE-2022-1884/): Remote Command Execution in gogs/gogs (critical 10.0)
- [CVE-2022-1986](https://insights.sbomify.com/CVE-2022-1986/): OS Command Injection in gogs/gogs (critical 10.0)
- [CVE-2022-1992](https://insights.sbomify.com/CVE-2022-1992/): Path Traversal in gogs/gogs (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64111 and fix it if it is affected.

What it is: CVE-2025-64111 is a critical command injection vulnerability in gogs, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64111 exists.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; no fix listed
- gogs.io/gogs (Go): affected all versions; fixed in 0.13.4
- gogs.io/gogs (Go): affected all versions; fixed in 0.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64111/ (Markdown: https://insights.sbomify.com/CVE-2025-64111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64111
- OSV: https://osv.dev/vulnerability/CVE-2025-64111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64111/
Summaries are generated and may contain mistakes; the official description above is the record.
