{"answers":{"affected":"2 open source packages ship an affected version, including statamic/cms.","exploited":"There is no known exploitation of CVE-2025-64112 in the wild and no public exploit code.","fix":"Upgrade statamic/cms to 5.22.1 or later.","what":"CVE-2025-64112 is a high-severity cross-site scripting vulnerability in statamic cms, published on 30 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-64112 and fix it if it is affected.\n\nWhat it is: CVE-2025-64112 is a high-severity cross-site scripting vulnerability in statamic cms, published on 30 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-64112 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- statamic/cms (Packagist): affected all versions; fixed in 5.22.1\n- statamic/cms (Packagist): affected all versions; fixed in 5.22.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64112/ (Markdown: https://insights.sbomify.com/CVE-2025-64112/index.md)","id":"CVE-2025-64112","markdown":"https://insights.sbomify.com/CVE-2025-64112/index.md","name":"CVE-2025-64112","record":{"aliases":["GHSA-g59r-24g3-h7cm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Statamic CMS","requires_auth":"low_privilege","summary":"Authenticated users can inject malicious JavaScript into Statamic CMS collections and taxonomies, leading to code execution or account takeover when viewed by privileged users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Statmatic is a Laravel and Git powered content management system (CMS). Stored XSS vulnerabilities in Collections and Taxonomies allow authenticated users with content creation permissions to inject malicious JavaScript that executes when viewed by higher-privileged users. This vulnerability is fixed in 5.22.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Statmatic vulnerable to Stored Cross-Site Scripting","id":"CVE-2025-64112","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Emby Server allows attackers to gain administrative server access without preconditions","id":"CVE-2025-64113"},"packages":[{"ecosystem":"Packagist","fixed":["5.22.1"],"introduced":["0"],"last_affected":[],"package":"statamic/cms","purl":null,"source":"GHSA-g59r-24g3-h7cm"},{"ecosystem":"Packagist","fixed":["5.22.1"],"introduced":["0"],"last_affected":[],"package":"statamic/cms","purl":"pkg:composer/statamic/cms","source":"GHSA-g59r-24g3-h7cm"}],"prev":{"headline":"Gogs's update .git/config file allows remote command execution","id":"CVE-2025-64111"},"products":["cms"],"published":"2025-10-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-30","vendors":["statamic"]},"summary":"Authenticated users can inject malicious JavaScript into Statamic CMS collections and taxonomies, leading to code execution or account takeover when viewed by privileged users.","url":"https://insights.sbomify.com/CVE-2025-64112/"}