# CVE-2025-64113: Emby Server allows attackers to gain administrative server access without preconditions


- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 9 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-95fv-5gfj-2r84

## What is CVE-2025-64113?

CVE-2025-64113 is a critical vulnerability in EmbySupport security, published on 9 Dec 2025. 

### Official description

Emby Server is a user-installable home media server. Versions below 4.9.1.81 allow an attacker to gain full administrative access to an Emby Server (for Emby Server administration, not at the OS level). Other than network access, no specific preconditions need to be fulfilled for a server to be vulnerable. This issue is fixed in version 4.9.1.81.

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password)

## Which versions are affected by CVE-2025-64113?

2 open source packages ship an affected version, including MediaBrowser.Server.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `MediaBrowser.Server.Core` | NuGet | All versions | 4.9.1.81 |
| `MediaBrowser.Server.Core` | NuGet | All versions | 4.9.1.81 |

Products: Emby Emby.

## How do I fix CVE-2025-64113?

Upgrade MediaBrowser.Server.Core to 4.9.1.81 or later.

## Is CVE-2025-64113 being exploited?

There is no known exploitation of CVE-2025-64113 in the wild and no public exploit code.

## Other vulnerabilities in EmbySupport security

- [CVE-2021-25827](https://insights.sbomify.com/CVE-2021-25827/): Auth bypass in n/a (critical 9.8)
- [CVE-2020-26948](https://insights.sbomify.com/CVE-2020-26948/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2025-64325](https://insights.sbomify.com/CVE-2025-64325/): Emby Server is Vulnerable to Remote Code Execution Through XSS in Admin Dashboard (high 8.4)
- [CVE-2021-25828](https://insights.sbomify.com/CVE-2021-25828/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2022-36223](https://insights.sbomify.com/CVE-2022-36223/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64113 and fix it if it is affected.

What it is: CVE-2025-64113 is a critical vulnerability in EmbySupport security, published on 9 Dec 2025. 
Exploitation: There is no known exploitation of CVE-2025-64113 in the wild and no public exploit code.

Affected packages and fixed versions:
- MediaBrowser.Server.Core (NuGet): affected all versions; fixed in 4.9.1.81
- MediaBrowser.Server.Core (NuGet): affected all versions; fixed in 4.9.1.81

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64113/ (Markdown: https://insights.sbomify.com/CVE-2025-64113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64113
- OSV: https://osv.dev/vulnerability/CVE-2025-64113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64113/
Summaries are generated and may contain mistakes; the official description above is the record.
