# CVE-2025-64132: Jenkins MCP Server Plugin does not perform permission checks in multiple MCP tools

> Attackers can trigger builds and access unauthorized job and cloud configuration data due to missing permission checks in the Jenkins MCP Server Plugin.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2025
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-mrpq-9jr3-rqq9

## What is CVE-2025-64132?

CVE-2025-64132 is a medium-severity missing authorization vulnerability in Jenkins MCP Server Plugin, published on 29 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins MCP Server Plugin 0.84.v50ca_24ef83f2 and earlier does not perform permission checks in multiple MCP tools, allowing attackers to trigger builds and obtain information about job and cloud configuration they should not be able to access.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-64132?

2 open source packages ship an affected version, including io.jenkins.plugins:mcp-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:mcp-server` | Maven | All versions | 0.86.v7d3355e6a |
| `io.jenkins.plugins:mcp-server` | Maven | All versions | 0.86.v7d3355e6a |

Products: Jenkins Mcp Server.

## How do I fix CVE-2025-64132?

Upgrade io.jenkins.plugins:mcp-server to 0.86.v7d3355e6a or later.

## Is CVE-2025-64132 being exploited?

There is no known exploitation of CVE-2025-64132 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins MCP Server Plugin

- [CVE-2026-57300](https://insights.sbomify.com/CVE-2026-57300/): Jenkins MCP Server Plugin missing a permission check (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64132 and fix it if it is affected.

What it is: CVE-2025-64132 is a medium-severity missing authorization vulnerability in Jenkins MCP Server Plugin, published on 29 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64132 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:mcp-server (Maven): affected all versions; fixed in 0.86.v7d3355e6a
- io.jenkins.plugins:mcp-server (Maven): affected all versions; fixed in 0.86.v7d3355e6a

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64132/ (Markdown: https://insights.sbomify.com/CVE-2025-64132/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64132
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64132
- OSV: https://osv.dev/vulnerability/CVE-2025-64132

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64132/
Summaries are generated and may contain mistakes; the official description above is the record.
