CVE-2025-64163 DataEase's DB2 is vulnerable to SSRF

High 8.9 Published Updated

Attackers can exploit missing dns:// protocol filtering to perform Server-Side Request Forgery attacks against DataEase deployments.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-64163?

CVE-2025-64163 is a high-severity server-side request forgery vulnerability in Dataease Dataease, published on 5 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

DataEase is an open source data visualization analysis tool. In versions 2.10.14 and below, the vendor added a blacklist to filter ldap:// and ldaps://. However, omission of protection for the dns:// protocol results in an SSRF vulnerability. This issue is fixed in version 2.10.15.

Weakness: CWE-918

Which versions are affected by CVE-2025-64163?

It affects 1 product.

Products include Dataease Dataease.

How do I fix CVE-2025-64163?

No fix has been published for CVE-2025-64163 yet. Limit exposure of the affected software until one is available.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2025-64163 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64163 exists.

All Dataease Dataease vulnerabilities

Sources

Also known as GHSA-8397-v66p-539m.

Is CVE-2025-64163 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free