CVE-2025-64164 DataEase is vulnerable to Oracle JNDI Injection

High 8.9 Published Updated

Attackers can execute arbitrary code via JNDI injection during Oracle JDBC connection establishment in DataEase.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-64164?

CVE-2025-64164 is a high-severity code injection vulnerability in Dataease Dataease, published on 6 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Dataease is an open source data visualization analysis tool. In versions 2.10.14 and below, DataEase did not properly filter when establishing JDBC connections to Oracle, resulting in a risk of JNDI injection (Java Naming and Directory Interface injection). This issue is fixed in version 2.10.15.

Weakness: CWE-502

Which versions are affected by CVE-2025-64164?

It affects 1 product.

Products include Dataease Dataease.

How do I fix CVE-2025-64164?

No fix has been published for CVE-2025-64164 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-64164 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64164 exists.

All Dataease Dataease vulnerabilities

Sources

Also known as GHSA-q754-4pc2-wjqw.

Is CVE-2025-64164 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free