# CVE-2025-64166: Mercurius: Incorrect Content-Type parsing can lead to CSRF attack

> Incorrect Content-Type parsing in Mercurius allows CSRF attacks, enabling unauthorized actions on behalf of authenticated users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 5 Mar 2026
- **Also known as:** GHSA-v66j-6wwf-jc57

## What is CVE-2025-64166?

CVE-2025-64166 is a medium-severity vulnerability in mercurius-js mercurius, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mercurius is a GraphQL adapter for Fastify. Prior to version 16.4.0, a cross-site request forgery (CSRF) vulnerability was identified. The issue arises from incorrect parsing of the Content-Type header in requests. Specifically, requests with Content-Type values such as application/x-www-form-urlencoded, multipart/form-data, or text/plain could be misinterpreted as application/json. This misinterpretation bypasses the preflight checks performed by the fetch() API, potentially allowing unauthorized actions to be performed on behalf of an authenticated user. This issue has been patched in version 16.4.0.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-64166?

2 open source packages ship an affected version, including mercurius. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mercurius` | npm | All versions | 16.4.0 |
| `mercurius` | npm | All versions | 16.4.0 |

Products: Mercurius Project Mercurius.

## How do I fix CVE-2025-64166?

Upgrade mercurius to 16.4.0 or later.

## Is CVE-2025-64166 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64166 exists.

## Other vulnerabilities in mercurius-js mercurius

- [CVE-2021-43801](https://insights.sbomify.com/CVE-2021-43801/): Uncaught Exception in mercurius (high 7.5)
- [CVE-2023-22477](https://insights.sbomify.com/CVE-2023-22477/): Mercurius is vulnerable to denial of service (DoS) when using subscriptions (medium 5.3)
- [CVE-2026-30241](https://insights.sbomify.com/CVE-2026-30241/): Mercurius: queryDepth limit bypassed for WebSocket subscriptions (low 2.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64166 and fix it if it is affected.

What it is: CVE-2025-64166 is a medium-severity vulnerability in mercurius-js mercurius, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64166 exists.

Affected packages and fixed versions:
- mercurius (npm): affected all versions; fixed in 16.4.0
- mercurius (npm): affected all versions; fixed in 16.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64166/ (Markdown: https://insights.sbomify.com/CVE-2025-64166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64166
- OSV: https://osv.dev/vulnerability/CVE-2025-64166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64166/
Summaries are generated and may contain mistakes; the official description above is the record.
