{"answers":{"affected":"3 open source packages ship an affected version, including agno.","exploited":"There is no known exploitation of CVE-2025-64168 in the wild and no public exploit code.","fix":"Upgrade agno to 2.2.2 or later.","what":"CVE-2025-64168 is a high-severity vulnerability in agno-agi agno, published on 31 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64168 and fix it if it is affected.\n\nWhat it is: CVE-2025-64168 is a high-severity vulnerability in agno-agi agno, published on 31 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-64168 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- agno (PyPI): affected from 2.0.0; fixed in 2.2.2\n- agno (PyPI): affected from 2.0.0; fixed in 2.2.2\n- agno (PyPI): affected from 2.0.0; fixed in 2.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64168/ (Markdown: https://insights.sbomify.com/CVE-2025-64168/index.md)","id":"CVE-2025-64168","markdown":"https://insights.sbomify.com/CVE-2025-64168/index.md","name":"CVE-2025-64168","record":{"aliases":["GHSA-vw84-hprm-cxmm","PYSEC-2026-1077"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python agent framework","requires_auth":"low_privilege","summary":"A race condition in the Agno framework allows session state to be incorrectly persisted, potentially exposing user data from one session to another.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"},{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"Agno is a multi-agent framework, runtime and control plane. From 2.0.0 to before 2.2.2, under high concurrency, when session_state is passed to Agent or Team during run or arun calls, a race condition can occur, causing a session_state to be assigned and persisted to the incorrect session. This may result in user data from one session being exposed to another user. This has been patched in version 2.2.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Agno session state overwrites between different sessions/users","id":"CVE-2025-64168","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"race_condition","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Wazuh NULL pointer dereference in fim_alert line 666","id":"CVE-2025-64169"},"packages":[{"ecosystem":"PyPI","fixed":["2.2.2"],"introduced":["2.0.0"],"last_affected":[],"package":"agno","purl":null,"source":"GHSA-vw84-hprm-cxmm"},{"ecosystem":"PyPI","fixed":["2.2.2"],"introduced":["2.0.0"],"last_affected":[],"package":"agno","purl":"pkg:pypi/agno","source":"GHSA-vw84-hprm-cxmm"},{"ecosystem":"PyPI","fixed":["2.2.2"],"introduced":["2.0.0"],"last_affected":[],"package":"agno","purl":"pkg:pypi/agno","source":"PYSEC-2026-1077"}],"prev":{"headline":"Combodo iTop vulnerable to reflected XSS in webservices/export.php","id":"CVE-2025-64167"},"products":["agno"],"published":"2025-10-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-31","vendors":["agno-agi"]},"summary":"A race condition in the Agno framework allows session state to be incorrectly persisted, potentially exposing user data from one session to another.","url":"https://insights.sbomify.com/CVE-2025-64168/"}